summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2008-10-24 12:17:16 +0000
committerHans de Graaff <graaff@gentoo.org>2008-10-24 12:17:16 +0000
commitc1c64581b5c6ad0f33f41efc8a366a351694e692 (patch)
tree8f6af761deae08724fe2a99120fa2c53efc2461b /dev-ruby
parentVersion bump for Rails 2.1.2 (diff)
downloadgentoo-2-c1c64581b5c6ad0f33f41efc8a366a351694e692.tar.gz
gentoo-2-c1c64581b5c6ad0f33f41efc8a366a351694e692.tar.bz2
gentoo-2-c1c64581b5c6ad0f33f41efc8a366a351694e692.zip
Version bump for Rails 2.1.2
(Portage version: 2.1.4.5)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activerecord/ChangeLog8
-rw-r--r--dev-ruby/activerecord/activerecord-2.1.2.ebuild21
2 files changed, 28 insertions, 1 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index 68b61228ba09..77964191467d 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.82 2008/10/20 19:33:47 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.83 2008/10/24 12:17:16 graaff Exp $
+
+*activerecord-2.1.2 (24 Oct 2008)
+
+ 24 Oct 2008; Hans de Graaff <graaff@gentoo.org>
+ +activerecord-2.1.2.ebuild:
+ Version bump for Rails 2.1.2
*activerecord-2.0.5 (20 Oct 2008)
diff --git a/dev-ruby/activerecord/activerecord-2.1.2.ebuild b/dev-ruby/activerecord/activerecord-2.1.2.ebuild
new file mode 100644
index 000000000000..d6874dac5dfe
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-2.1.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.1.2.ebuild,v 1.1 2008/10/24 12:17:16 graaff Exp $
+
+inherit ruby gems
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+
+LICENSE="MIT"
+SLOT="2.1"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mysql postgres sqlite sqlite3"
+RESTRICT="test"
+
+DEPEND=">=dev-lang/ruby-1.8.5
+ ~dev-ruby/activesupport-2.1.2
+ sqlite? ( >=dev-ruby/sqlite-ruby-2.2.2 )
+ sqlite3? ( dev-ruby/sqlite3-ruby )
+ mysql? ( >=dev-ruby/mysql-ruby-2.7 )
+ postgres? ( >=dev-ruby/ruby-postgres-0.7.1 )"