summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2008-10-20 19:35:46 +0000
committerHans de Graaff <graaff@gentoo.org>2008-10-20 19:35:46 +0000
commitbcedd0a09b3b00f75bdfc3ff215f77963b9fbc83 (patch)
tree08a68883391e0ea71c7f8370d4cfe79abf1a8c86 /dev-ruby
parentBump to 2.24.1. Translation updates. (diff)
downloadgentoo-2-bcedd0a09b3b00f75bdfc3ff215f77963b9fbc83.tar.gz
gentoo-2-bcedd0a09b3b00f75bdfc3ff215f77963b9fbc83.tar.bz2
gentoo-2-bcedd0a09b3b00f75bdfc3ff215f77963b9fbc83.zip
Version bump for Rails 2.0.5
(Portage version: 2.1.4.5)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rails/ChangeLog7
-rw-r--r--dev-ruby/rails/rails-2.0.5.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index c7dc17b2114d..fd9749b559da 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.112 2008/09/13 09:09:14 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.113 2008/10/20 19:35:46 graaff Exp $
+
+*rails-2.0.5 (20 Oct 2008)
+
+ 20 Oct 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.0.5.ebuild:
+ Version bump for Rails 2.0.5
*rails-2.1.1 (13 Sep 2008)
diff --git a/dev-ruby/rails/rails-2.0.5.ebuild b/dev-ruby/rails/rails-2.0.5.ebuild
new file mode 100644
index 000000000000..2f72d86208a3
--- /dev/null
+++ b/dev-ruby/rails/rails-2.0.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-2.0.5.ebuild,v 1.1 2008/10/20 19:35:46 graaff Exp $
+
+inherit ruby gems
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="fastcgi"
+DEPEND=">=dev-lang/ruby-1.8.5
+ >=app-admin/eselect-rails-0.11
+ >=dev-ruby/rake-0.7.2
+ ~dev-ruby/activerecord-2.0.5
+ ~dev-ruby/activeresource-2.0.5
+ ~dev-ruby/activesupport-2.0.5
+ ~dev-ruby/actionmailer-2.0.5
+ ~dev-ruby/actionpack-2.0.5
+ !<dev-ruby/rails-1.1.6-r1"
+
+RDEPEND="${DEPEND}
+ fastcgi? ( >=dev-ruby/ruby-fcgi-0.8.6 )"
+
+src_install() {
+ gems_src_install
+ # Rename slotted files that may clash so that eselect can handle
+ # them
+ mv "${D}/usr/bin/rails" "${D}/usr/bin/rails-${PV}"
+ mv "${D}/${GEMSDIR}/bin/rails" "${D}/${GEMSDIR}/bin/rails-${PV}"
+}
+
+pkg_postinst() {
+ einfo "To select between slots of rails, use:"
+ einfo "\teselect rails"
+ # Bring users to rails 2.0.x by default when updating
+ eselect rails update 2
+
+ ewarn "All database USE flags have been moved to dev-ruby/activerecord"
+}
+
+pkg_postrm() {
+ # Drop users back to rails 1.2.x when they remove 2.0.x
+ eselect rails update 1.2
+}