summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2012-07-08 21:46:13 +0000
committerNaohiro Aota <naota@gentoo.org>2012-07-08 21:46:13 +0000
commitb8e7d8990477b969d509e3d2d3260622105dc1ce (patch)
tree6794b9c7121e2089ea164dbff5999560cbe17664 /dev-ruby
parentBump to 1.0.2 (diff)
downloadgentoo-2-b8e7d8990477b969d509e3d2d3260622105dc1ce.tar.gz
gentoo-2-b8e7d8990477b969d509e3d2d3260622105dc1ce.tar.bz2
gentoo-2-b8e7d8990477b969d509e3d2d3260622105dc1ce.zip
Bump to 1.2.1
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/termcolor/ChangeLog11
-rw-r--r--dev-ruby/termcolor/termcolor-1.2.0.ebuild4
-rw-r--r--dev-ruby/termcolor/termcolor-1.2.1.ebuild29
3 files changed, 39 insertions, 5 deletions
diff --git a/dev-ruby/termcolor/ChangeLog b/dev-ruby/termcolor/ChangeLog
index 5a7e94e4bdc1..e98e5471a51b 100644
--- a/dev-ruby/termcolor/ChangeLog
+++ b/dev-ruby/termcolor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/termcolor
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/termcolor/ChangeLog,v 1.2 2011/11/20 09:30:50 graaff Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/termcolor/ChangeLog,v 1.3 2012/07/08 21:46:13 naota Exp $
+
+*termcolor-1.2.1 (08 Jul 2012)
+
+ 08 Jul 2012; Naohiro Aota <naota@gentoo.org> +termcolor-1.2.1.ebuild,
+ termcolor-1.2.0.ebuild:
+ Bump to 1.2.1
20 Nov 2011; Hans de Graaff <graaff@gentoo.org> termcolor-1.2.0.ebuild:
Fix building with USE=doc, fix rspec dependency to right slot. Fix running
@@ -12,4 +18,3 @@
+metadata.xml:
New ebuild dev-ruby/termcolor. ebuild written by Matsuu Takuto
<matsuu@gentoo.org>
-
diff --git a/dev-ruby/termcolor/termcolor-1.2.0.ebuild b/dev-ruby/termcolor/termcolor-1.2.0.ebuild
index 36fc5a9d97d8..b92f29ceaf4d 100644
--- a/dev-ruby/termcolor/termcolor-1.2.0.ebuild
+++ b/dev-ruby/termcolor/termcolor-1.2.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/termcolor/termcolor-1.2.0.ebuild,v 1.2 2011/11/20 09:30:50 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/termcolor/termcolor-1.2.0.ebuild,v 1.3 2012/07/08 21:46:13 naota Exp $
EAPI="2"
#*** Using highline effectively in JRuby requires manually installing the ffi-ncurses gem.
diff --git a/dev-ruby/termcolor/termcolor-1.2.1.ebuild b/dev-ruby/termcolor/termcolor-1.2.1.ebuild
new file mode 100644
index 000000000000..7b5f5b449d0e
--- /dev/null
+++ b/dev-ruby/termcolor/termcolor-1.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/termcolor/termcolor-1.2.1.ebuild,v 1.1 2012/07/08 21:46:13 naota Exp $
+
+EAPI="2"
+#*** Using highline effectively in JRuby requires manually installing the ffi-ncurses gem.
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="a library for ANSI color formatting like HTML for output in terminal"
+HOMEPAGE="http://termcolor.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "dev-ruby/rspec:0"
+ruby_add_rdepend ">=dev-ruby/highline-1.5.0"
+
+each_ruby_test() {
+ ${RUBY} -S spec spec || die
+}