summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-07-20 06:45:21 +0000
committerHans de Graaff <graaff@gentoo.org>2013-07-20 06:45:21 +0000
commitb864b86453adea87cd706624e6d7ffeef0234064 (patch)
tree7262457fa44995fdbf2cd1ae43358c233ebccfb4 /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-b864b86453adea87cd706624e6d7ffeef0234064.tar.gz
gentoo-2-b864b86453adea87cd706624e6d7ffeef0234064.tar.bz2
gentoo-2-b864b86453adea87cd706624e6d7ffeef0234064.zip
Version bump.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rspec-expectations/ChangeLog8
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-2.14.0.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-ruby/rspec-expectations/ChangeLog b/dev-ruby/rspec-expectations/ChangeLog
index 86c1f220afaa..1a1ef16aefaf 100644
--- a/dev-ruby/rspec-expectations/ChangeLog
+++ b/dev-ruby/rspec-expectations/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rspec-expectations
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.53 2013/07/20 06:17:19 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.54 2013/07/20 06:45:21 graaff Exp $
+
+*rspec-expectations-2.14.0 (20 Jul 2013)
+
+ 20 Jul 2013; Hans de Graaff <graaff@gentoo.org>
+ +rspec-expectations-2.14.0.ebuild:
+ Version bump.
20 Jul 2013; Hans de Graaff <graaff@gentoo.org>
-rspec-expectations-2.6.0-r1.ebuild:
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-2.14.0.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-2.14.0.ebuild
new file mode 100644
index 000000000000..511395be289b
--- /dev/null
+++ b/dev-ruby/rspec-expectations/rspec-expectations-2.14.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/rspec-expectations-2.14.0.ebuild,v 1.1 2013/07/20 06:45:21 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.1.3"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rspec-core-2.11.0:2
+ >=dev-ruby/rspec-mocks-2.14.0:2
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm Gemfile || die
+
+ # Remove .rspec options to avoid dependency on newer rspec when
+ # bootstrapping.
+ rm .rspec || die
+
+ # fix up the gemspecs
+ sed -i \
+ -e '/git ls/d' \
+ -e '/add_development_dependency/d' \
+ "${RUBY_FAKEGEM_GEMSPEC}" || die
+}