summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-04-26 15:09:54 +0000
committerHans de Graaff <graaff@gentoo.org>2014-04-26 15:09:54 +0000
commitb2d246b8d18e313a86d216d09901b34f51946440 (patch)
tree8af550fd8d6ae78f4750d79fa52276b3accea93c /dev-ruby
parentVersion bump for Rails 4.1. Drop x86, bug 508780. (diff)
downloadgentoo-2-b2d246b8d18e313a86d216d09901b34f51946440.tar.gz
gentoo-2-b2d246b8d18e313a86d216d09901b34f51946440.tar.bz2
gentoo-2-b2d246b8d18e313a86d216d09901b34f51946440.zip
Version bump for Rails 4.1. Drop x86, bug 508780.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actionmailer/ChangeLog7
-rw-r--r--dev-ruby/actionmailer/actionmailer-4.1.0.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index 168c11760cf5..e983c7b262e3 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.255 2014/04/21 13:00:18 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.256 2014/04/26 15:09:54 graaff Exp $
+
+*actionmailer-4.1.0 (26 Apr 2014)
+
+ 26 Apr 2014; Hans de Graaff <graaff@gentoo.org> +actionmailer-4.1.0.ebuild:
+ Version bump for Rails 4.1. Drop x86, bug 508780.
21 Apr 2014; Hans de Graaff <graaff@gentoo.org> -actionmailer-3.2.16.ebuild,
-actionmailer-4.0.2.ebuild:
diff --git a/dev-ruby/actionmailer/actionmailer-4.1.0.ebuild b/dev-ruby/actionmailer/actionmailer-4.1.0.ebuild
new file mode 100644
index 000000000000..c6aba3ab4c1a
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-4.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-4.1.0.ebuild,v 1.1 2014/04/26 15:09:54 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.5.4:2.5"
+ruby_add_bdepend "test? (
+ dev-ruby/test-unit:2
+ dev-ruby/mocha:0.14
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Make sure we use the test-unit gem since ruby18 does not provide
+ # all the test-unit features needed.
+ sed -i -e '1igem "test-unit"' test/abstract_unit.rb || die
+}