summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-16 16:46:48 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-16 16:46:48 +0000
commitac968f690ae9e1b1fc4d881749d12302adfea37b (patch)
tree70eadd75785e7fd6d528f1e92028ec06d69b453a /dev-ruby
parentx86 stable, see bug 422051 (diff)
downloadgentoo-2-ac968f690ae9e1b1fc4d881749d12302adfea37b.tar.gz
gentoo-2-ac968f690ae9e1b1fc4d881749d12302adfea37b.tar.bz2
gentoo-2-ac968f690ae9e1b1fc4d881749d12302adfea37b.zip
Remove old; bump to EAPI=4; fix dependencies; split compile function in configure+compile; remove FAKEGEM_NAME.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/fcgi/ChangeLog10
-rw-r--r--dev-ruby/fcgi/fcgi-0.8.8-r2.ebuild27
-rw-r--r--dev-ruby/fcgi/fcgi-0.8.8.ebuild39
3 files changed, 22 insertions, 54 deletions
diff --git a/dev-ruby/fcgi/ChangeLog b/dev-ruby/fcgi/ChangeLog
index 2acc15d08ddf..8bf009172a19 100644
--- a/dev-ruby/fcgi/ChangeLog
+++ b/dev-ruby/fcgi/ChangeLog
@@ -1,6 +1,11 @@
-# ChangeLog for dev-ruby/ruby-fcgi
+# ChangeLog for dev-ruby/fcgi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fcgi/ChangeLog,v 1.1 2012/08/16 03:43:57 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fcgi/ChangeLog,v 1.2 2012/08/16 16:46:48 flameeyes Exp $
+
+ 16 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> -fcgi-0.8.8.ebuild,
+ fcgi-0.8.8-r2.ebuild:
+ Remove old; bump to EAPI=4; fix dependencies; split compile function in
+ configure+compile; remove FAKEGEM_NAME.
10 Aug 2012; Anthony G. Basile <blueness@gentoo.org> ChangeLog:
Fix failed gpg signiture of manifest
@@ -205,4 +210,3 @@
+ruby-fcgi-0.8.4.ebuild:
Initial import. Ebuild submitted by awk <glawk01@awks.org>,
closing bug #59042.
-
diff --git a/dev-ruby/fcgi/fcgi-0.8.8-r2.ebuild b/dev-ruby/fcgi/fcgi-0.8.8-r2.ebuild
index e977b4809d0a..bb327b0d7eb9 100644
--- a/dev-ruby/fcgi/fcgi-0.8.8-r2.ebuild
+++ b/dev-ruby/fcgi/fcgi-0.8.8-r2.ebuild
@@ -1,18 +1,16 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fcgi/fcgi-0.8.8-r2.ebuild,v 1.1 2012/08/16 03:43:57 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fcgi/fcgi-0.8.8-r2.ebuild,v 1.2 2012/08/16 16:46:48 flameeyes Exp $
-EAPI=2
+EAPI=4
USE_RUBY="ruby18 ruby19 ree18 jruby"
-RUBY_FAKEGEM_NAME="${PN/ruby-/}"
-
RUBY_FAKEGEM_TASK_TEST=""
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="README README.signals ChangeLog"
-inherit ruby-fakegem eutils
+inherit multilib ruby-fakegem
DESCRIPTION="FastCGI library for Ruby"
HOMEPAGE="http://rubyforge.org/projects/fcgi/"
@@ -20,20 +18,25 @@ HOMEPAGE="http://rubyforge.org/projects/fcgi/"
KEYWORDS="amd64 ~hppa ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
LICENSE="Ruby"
-DEPEND="dev-libs/fcgi"
-RDEPEND="${DEPEND}"
+DEPEND+=" dev-libs/fcgi"
+RDEPEND+=" dev-libs/fcgi"
IUSE=""
SLOT="0"
+each_ruby_configure() {
+ case ${RUBY} in
+ *ruby18|*rubyee18)
+ ${RUBY} -C ext/fcgi extconf.rb || die "extconf failed"
+ ;;
+ esac
+}
+
each_ruby_compile() {
case ${RUBY} in
*ruby18|*rubyee18)
- pushd ext/fcgi
- ${RUBY} extconf.rb || die "extconf failed"
- emake || die "emake ext failed"
- popd
- cp ext/fcgi/fcgi.so lib || die
+ emake -C ext/fcgi
+ cp ext/fcgi/fcgi$(get_modname) lib || die
;;
esac
}
diff --git a/dev-ruby/fcgi/fcgi-0.8.8.ebuild b/dev-ruby/fcgi/fcgi-0.8.8.ebuild
deleted file mode 100644
index 78f3be6f6450..000000000000
--- a/dev-ruby/fcgi/fcgi-0.8.8.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fcgi/fcgi-0.8.8.ebuild,v 1.1 2012/08/16 03:43:57 flameeyes Exp $
-
-EAPI=2
-USE_RUBY="ruby18 jruby"
-
-RUBY_FAKEGEM_NAME="${PN/ruby-/}"
-
-RUBY_FAKEGEM_TASK_TEST=""
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="README README.signals ChangeLog"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="FastCGI library for Ruby"
-HOMEPAGE="http://rubyforge.org/projects/fcgi/"
-
-KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-LICENSE="Ruby"
-
-DEPEND="dev-libs/fcgi"
-RDEPEND="${DEPEND}"
-
-IUSE=""
-SLOT="0"
-
-each_ruby_compile() {
- case ${RUBY} in
- *ruby18)
- pushd ext/fcgi
- ${RUBY} extconf.rb || die "extconf failed"
- emake || die "emake ext failed"
- popd
- cp ext/fcgi/fcgi.so lib || die
- ;;
- esac
-}