summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-04-06 08:09:01 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-04-06 08:09:01 +0000
commita4c96c772145074af482b5ac249cc48a6fa68667 (patch)
tree19e22f4564fb1d7e392317646d67f5730986fb48 /dev-ruby
parentStable on amd64 wrt bug #308245 (diff)
downloadgentoo-2-a4c96c772145074af482b5ac249cc48a6fa68667.tar.gz
gentoo-2-a4c96c772145074af482b5ac249cc48a6fa68667.tar.bz2
gentoo-2-a4c96c772145074af482b5ac249cc48a6fa68667.zip
Version bump to latest version.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/storable/ChangeLog8
-rw-r--r--dev-ruby/storable/storable-0.7.1.ebuild (renamed from dev-ruby/storable/storable-0.6.5.ebuild)25
2 files changed, 28 insertions, 5 deletions
diff --git a/dev-ruby/storable/ChangeLog b/dev-ruby/storable/ChangeLog
index 86d2040c9760..efdb382ee64e 100644
--- a/dev-ruby/storable/ChangeLog
+++ b/dev-ruby/storable/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/storable
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/ChangeLog,v 1.4 2010/03/26 07:08:12 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/ChangeLog,v 1.5 2010/04/06 08:09:01 flameeyes Exp $
+
+*storable-0.7.1 (06 Apr 2010)
+
+ 06 Apr 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ -storable-0.6.5.ebuild, +storable-0.7.1.ebuild:
+ Version bump to latest version.
*storable-0.6.5 (25 Mar 2010)
diff --git a/dev-ruby/storable/storable-0.6.5.ebuild b/dev-ruby/storable/storable-0.7.1.ebuild
index 33cdacf82276..b67382904ad8 100644
--- a/dev-ruby/storable/storable-0.6.5.ebuild
+++ b/dev-ruby/storable/storable-0.7.1.ebuild
@@ -1,20 +1,17 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/storable-0.6.5.ebuild,v 1.1 2010/03/26 07:08:12 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/storable-0.7.1.ebuild,v 1.1 2010/04/06 08:09:01 flameeyes Exp $
EAPI=2
USE_RUBY="ruby18 ruby19 jruby"
RUBY_FAKEGEM_TASK_TEST=""
-RESTRICT=test
RUBY_FAKEGEM_TASK_DOC="rdoc"
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
-RUBY_FAKEGEM_BINWRAP="ec2sh"
-
inherit ruby-fakegem
DESCRIPTION="Marshal Ruby classes into and out of multiple formats"
@@ -24,3 +21,23 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+
+SRC_URI="http://github.com/delano/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
+S="${WORKDIR}/delano-${PN}-a465c45"
+
+ruby_add_bdepend test dev-ruby/tryouts
+
+all_ruby_prepare() {
+ mv bin examples || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S sergeant || die "tests failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/* || die
+}