summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-04-07 08:50:24 +0000
committerHans de Graaff <graaff@gentoo.org>2012-04-07 08:50:24 +0000
commita425dac0a3c29e8ecc85de699ee96247c3ab8b90 (patch)
treea1c4a2df10610037ef20789f6221aac4076188f7 /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-a425dac0a3c29e8ecc85de699ee96247c3ab8b90.tar.gz
gentoo-2-a425dac0a3c29e8ecc85de699ee96247c3ab8b90.tar.bz2
gentoo-2-a425dac0a3c29e8ecc85de699ee96247c3ab8b90.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/coderay/ChangeLog7
-rw-r--r--dev-ruby/coderay/coderay-1.0.6.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-ruby/coderay/ChangeLog b/dev-ruby/coderay/ChangeLog
index af74be602608..594574cb3b64 100644
--- a/dev-ruby/coderay/ChangeLog
+++ b/dev-ruby/coderay/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/coderay
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/ChangeLog,v 1.50 2012/03/08 15:19:24 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/ChangeLog,v 1.51 2012/04/07 08:50:24 graaff Exp $
+
+*coderay-1.0.6 (07 Apr 2012)
+
+ 07 Apr 2012; Hans de Graaff <graaff@gentoo.org> +coderay-1.0.6.ebuild:
+ Version bump.
08 Mar 2012; Brent Baude <ranger@gentoo.org> coderay-0.9.8.ebuild:
Marking coderay-0.9.8 ppc64 for bug 393665
diff --git a/dev-ruby/coderay/coderay-1.0.6.ebuild b/dev-ruby/coderay/coderay-1.0.6.ebuild
new file mode 100644
index 000000000000..9f6a9ef1f710
--- /dev/null
+++ b/dev-ruby/coderay/coderay-1.0.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/coderay-1.0.6.ebuild,v 1.1 2012/04/07 08:50:24 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18 ruby19"
+
+# The test target also contains test:exe but that requires
+# shoulda-context which we do not have packaged yet.
+RUBY_FAKEGEM_TASK_TEST="test:functional test:units"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="Changes-pre-1.0.textile Changes.textile FOLDERS README_INDEX.rdoc README.textile"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby library for syntax highlighting."
+HOMEPAGE="http://coderay.rubychan.de/"
+SRC_URI="https://github.com/rubychan/coderay/tarball/v${PV} -> ${P}.tgz"
+
+RUBY_S="rubychan-coderay-*"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Redcloth is optional but automagically tested, so we add this
+# dependency to ensure that we get at least a version that works: bug
+# 330621. We use this convoluted way because redcloth isn't available
+# yet for jruby.
+USE_RUBY="${USE_RUBY/jruby/}" ruby_add_bdepend "test? ( >=dev-ruby/redcloth-4.2.2 )"