summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-10-16 06:07:34 +0000
committerHans de Graaff <graaff@gentoo.org>2013-10-16 06:07:34 +0000
commita2eafb862ccaa9529c1ffd8014aebefb9cec6640 (patch)
tree0fa35b21fea28e85351ef2f637dd88c25e7a3827 /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-a2eafb862ccaa9529c1ffd8014aebefb9cec6640.tar.gz
gentoo-2-a2eafb862ccaa9529c1ffd8014aebefb9cec6640.tar.bz2
gentoo-2-a2eafb862ccaa9529c1ffd8014aebefb9cec6640.zip
Add ruby20, fixing bug 476230.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/bundler/ChangeLog7
-rw-r--r--dev-ruby/bundler/bundler-1.3.5-r1.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-ruby/bundler/ChangeLog b/dev-ruby/bundler/ChangeLog
index 6b51fe67e2ec..6974cb0b1425 100644
--- a/dev-ruby/bundler/ChangeLog
+++ b/dev-ruby/bundler/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/bundler
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/ChangeLog,v 1.57 2013/09/22 06:49:56 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/ChangeLog,v 1.58 2013/10/16 06:07:34 graaff Exp $
+
+*bundler-1.3.5-r1 (16 Oct 2013)
+
+ 16 Oct 2013; Hans de Graaff <graaff@gentoo.org> +bundler-1.3.5-r1.ebuild:
+ Add ruby20, fixing bug 476230.
22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> bundler-1.3.5.ebuild:
Stable for x86, wrt bug #484444
diff --git a/dev-ruby/bundler/bundler-1.3.5-r1.ebuild b/dev-ruby/bundler/bundler-1.3.5-r1.ebuild
new file mode 100644
index 000000000000..4cf54157981d
--- /dev/null
+++ b/dev-ruby/bundler/bundler-1.3.5-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/bundler-1.3.5-r1.ebuild,v 1.1 2013/10/16 06:07:34 graaff Exp $
+
+EAPI=5
+
+# jruby → Many tests fail and test suite hangs.
+USE_RUBY="ruby18 ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+# No documentation task
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md ISSUES.md UPGRADING.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An easy way to vendor gem dependencies"
+HOMEPAGE="http://github.com/carlhuda/bundler"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend virtual/rubygems
+
+ruby_add_bdepend "test? ( app-text/ronn )"
+
+RDEPEND+=" dev-vcs/git"
+DEPEND+=" test? ( dev-vcs/git )"
+
+all_ruby_prepare() {
+ # Bundler only supports running the specs from git:
+ # http://github.com/carlhuda/bundler/issues/issue/738
+ sed -i -e '/when Bundler is bundled/,/^ end/ s:^:#:' spec/runtime/setup_spec.rb || die
+
+ # Fails randomly and no clear cause can be found. Might be related
+ # to bug 346357. This was broken in previous releases without a
+ # failing spec, so patch out this spec for now since it is not a
+ # regression.
+ sed -i -e '/works when you bundle exec bundle/,/^ end/ s:^:#:' spec/install/deploy_spec.rb || die
+}