summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-04-04 09:59:57 +0000
committerHans de Graaff <graaff@gentoo.org>2012-04-04 09:59:57 +0000
commita03a769b4e824f8b225cc138270d21d711fc7f64 (patch)
tree5e2ce72b414dfdbd54cf8899c5d141dfe2b16618 /dev-ruby
parentAdd missing ~ppc64 which was most likely the intention given that rails itsel... (diff)
downloadgentoo-2-a03a769b4e824f8b225cc138270d21d711fc7f64.tar.gz
gentoo-2-a03a769b4e824f8b225cc138270d21d711fc7f64.tar.bz2
gentoo-2-a03a769b4e824f8b225cc138270d21d711fc7f64.zip
Version bump for security bug 406547.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rails/ChangeLog7
-rw-r--r--dev-ruby/rails/rails-3.0.12.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index 7dacd50900ad..63b0514cc7cc 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.213 2012/03/11 14:11:35 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.214 2012/04/04 09:59:57 graaff Exp $
+
+*rails-3.0.12 (04 Apr 2012)
+
+ 04 Apr 2012; Hans de Graaff <graaff@gentoo.org> +rails-3.0.12.ebuild:
+ Version bump for security bug 406547.
11 Mar 2012; Brent Baude <ranger@gentoo.org> rails-3.1.3.ebuild:
Marking rails-3.1.3 ~ppc64 for bug 396547
diff --git a/dev-ruby/rails/rails-3.0.12.ebuild b/dev-ruby/rails/rails-3.0.12.ebuild
new file mode 100644
index 000000000000..08dfd10040a8
--- /dev/null
+++ b/dev-ruby/rails/rails-3.0.12.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-3.0.12.ebuild,v 1.1 2012/04/04 09:59:57 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-rails-0.16"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionmailer-${PV}
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activeresource-${PV}
+ ~dev-ruby/activesupport-${PV}
+ =dev-ruby/bundler-1.0*
+ ~dev-ruby/railties-${PV}"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rails rails-${PV}
+}
+
+pkg_postinst() {
+ elog "To select between slots of rails, use:"
+ elog "\teselect rails"
+
+ eselect rails update
+}
+
+pkg_postrm() {
+ eselect rails update
+}