summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-02-05 00:03:59 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-02-05 00:03:59 +0000
commit970b1746d4b3b8e36a8c05341abc7f9e25ff16ce (patch)
tree42d5414fbb960e8db74bfdc7efdba71fca0e1442 /dev-ruby
parentVersion bump to be compatible with sword-1.7 (diff)
downloadgentoo-2-970b1746d4b3b8e36a8c05341abc7f9e25ff16ce.tar.gz
gentoo-2-970b1746d4b3b8e36a8c05341abc7f9e25ff16ce.tar.bz2
gentoo-2-970b1746d4b3b8e36a8c05341abc7f9e25ff16ce.zip
Version bump. Add ruby21 target.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/tins/ChangeLog7
-rw-r--r--dev-ruby/tins/tins-0.13.2.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-ruby/tins/ChangeLog b/dev-ruby/tins/ChangeLog
index 9c434092c9ea..5c449efba9b1 100644
--- a/dev-ruby/tins/ChangeLog
+++ b/dev-ruby/tins/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/tins
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tins/ChangeLog,v 1.32 2014/01/19 09:54:58 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tins/ChangeLog,v 1.33 2014/02/05 00:03:59 mrueg Exp $
+
+*tins-0.13.2 (05 Feb 2014)
+
+ 05 Feb 2014; Manuel Rüger <mrueg@gentoo.org> +tins-0.13.2.ebuild:
+ Version bump. Add ruby21 target.
19 Jan 2014; Pacho Ramos <pacho@gentoo.org> tins-0.13.1.ebuild:
amd64 stable, bug 490178
diff --git a/dev-ruby/tins/tins-0.13.2.ebuild b/dev-ruby/tins/tins-0.13.2.ebuild
new file mode 100644
index 000000000000..a9f86a7ae974
--- /dev/null
+++ b/dev-ruby/tins/tins-0.13.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tins/tins-0.13.2.ebuild,v 1.1 2014/02/05 00:03:59 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="All the stuff that isn't good enough for a real library."
+HOMEPAGE="http://github.com/flori/tins"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib tests/*_test.rb
+}