summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-03-16 06:24:26 +0000
committerHans de Graaff <graaff@gentoo.org>2010-03-16 06:24:26 +0000
commit967cebbc7c3ff61050a86b65bc5d871cb425187d (patch)
tree62f70257afa234e8252bad523f3a118c99c55436 /dev-ruby
parentold (diff)
downloadgentoo-2-967cebbc7c3ff61050a86b65bc5d871cb425187d.tar.gz
gentoo-2-967cebbc7c3ff61050a86b65bc5d871cb425187d.tar.bz2
gentoo-2-967cebbc7c3ff61050a86b65bc5d871cb425187d.zip
Version bump: fix for rolling back on local copy errors. Install VERSION file to make cap -V work.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/capistrano/ChangeLog8
-rw-r--r--dev-ruby/capistrano/capistrano-2.5.18.ebuild35
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-ruby/capistrano/ChangeLog b/dev-ruby/capistrano/ChangeLog
index 87ee3861b6b7..11330d1d9321 100644
--- a/dev-ruby/capistrano/ChangeLog
+++ b/dev-ruby/capistrano/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/capistrano
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/ChangeLog,v 1.53 2010/03/14 13:06:33 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/ChangeLog,v 1.54 2010/03/16 06:24:26 graaff Exp $
+
+*capistrano-2.5.18 (16 Mar 2010)
+
+ 16 Mar 2010; Hans de Graaff <graaff@gentoo.org> +capistrano-2.5.18.ebuild:
+ Version bump: fix for rolling back on local copy errors. Install VERSION
+ file to make cap -V work.
*capistrano-2.5.17 (14 Mar 2010)
diff --git a/dev-ruby/capistrano/capistrano-2.5.18.ebuild b/dev-ruby/capistrano/capistrano-2.5.18.ebuild
new file mode 100644
index 000000000000..15a2da1a12f5
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-2.5.18.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/capistrano-2.5.18.ebuild,v 1.1 2010/03/16 06:24:26 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="http://capify.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/net-ssh-2.0.14
+ >=dev-ruby/net-sftp-2.0.2
+ >=dev-ruby/net-scp-1.0.2
+ >=dev-ruby/net-ssh-gateway-1.0.0
+ >=dev-ruby/highline-1.2.7"
+ruby_add_bdepend test "dev-ruby/mocha"
+
+RDEPEND="!dev-ruby/capistrano-launcher"
+
+each_ruby_prepare() {
+ # Remove Jeweler check_dependencies task
+ sed -i '/check_dependencies/d' Rakefile
+}