summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-04 16:04:59 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-04 16:04:59 +0000
commit91d4b778f96f185f0e6545793c6af6a227eff641 (patch)
tree72bd50c5da215d8a465254eda1fef52b93272fbf /dev-ruby
parentStable for HPPA (bug #467274). (diff)
downloadgentoo-2-91d4b778f96f185f0e6545793c6af6a227eff641.tar.gz
gentoo-2-91d4b778f96f185f0e6545793c6af6a227eff641.tar.bz2
gentoo-2-91d4b778f96f185f0e6545793c6af6a227eff641.zip
Add ruby20 target. Fix USE=doc. Drop old.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/hoe-seattlerb/ChangeLog8
-rw-r--r--dev-ruby/hoe-seattlerb/hoe-seattlerb-1.2.9.ebuild25
-rw-r--r--dev-ruby/hoe-seattlerb/hoe-seattlerb-1.3.2-r1.ebuild (renamed from dev-ruby/hoe-seattlerb/hoe-seattlerb-1.3.1.ebuild)9
3 files changed, 14 insertions, 28 deletions
diff --git a/dev-ruby/hoe-seattlerb/ChangeLog b/dev-ruby/hoe-seattlerb/ChangeLog
index 6334c0bf899f..6bcc90977978 100644
--- a/dev-ruby/hoe-seattlerb/ChangeLog
+++ b/dev-ruby/hoe-seattlerb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/hoe-seattlerb
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe-seattlerb/ChangeLog,v 1.49 2013/07/25 14:51:46 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe-seattlerb/ChangeLog,v 1.50 2013/10/04 16:04:59 mrueg Exp $
+
+*hoe-seattlerb-1.3.2-r1 (04 Oct 2013)
+
+ 04 Oct 2013; Manuel Rüger <mrueg@gentoo.org> +hoe-seattlerb-1.3.2-r1.ebuild,
+ -hoe-seattlerb-1.2.9.ebuild, -hoe-seattlerb-1.3.1.ebuild:
+ Add ruby20 target. Fix USE=doc. Drop old.
*hoe-seattlerb-1.3.2 (25 Jul 2013)
diff --git a/dev-ruby/hoe-seattlerb/hoe-seattlerb-1.2.9.ebuild b/dev-ruby/hoe-seattlerb/hoe-seattlerb-1.2.9.ebuild
deleted file mode 100644
index f2d7905adf5d..000000000000
--- a/dev-ruby/hoe-seattlerb/hoe-seattlerb-1.2.9.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe-seattlerb/hoe-seattlerb-1.2.9.ebuild,v 1.2 2013/01/15 05:50:56 zerochaos Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-# no tests present
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Hoe plugins providing tasks used by seattle.rb"
-HOMEPAGE="http://seattlerb.rubyforge.org/hoe-seattlerb"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_bdepend "doc? ( >=dev-ruby/hoe-2.12 )"
diff --git a/dev-ruby/hoe-seattlerb/hoe-seattlerb-1.3.1.ebuild b/dev-ruby/hoe-seattlerb/hoe-seattlerb-1.3.2-r1.ebuild
index 8e45e1998598..c514fd3834cf 100644
--- a/dev-ruby/hoe-seattlerb/hoe-seattlerb-1.3.1.ebuild
+++ b/dev-ruby/hoe-seattlerb/hoe-seattlerb-1.3.2-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe-seattlerb/hoe-seattlerb-1.3.1.ebuild,v 1.1 2013/07/17 07:13:02 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe-seattlerb/hoe-seattlerb-1.3.2-r1.ebuild,v 1.1 2013/10/04 16:04:59 mrueg Exp $
EAPI=5
-USE_RUBY="ruby18 ruby19 jruby"
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
# no tests present
RUBY_FAKEGEM_TASK_TEST=""
@@ -23,3 +23,8 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd6
IUSE=""
ruby_add_bdepend "doc? ( >=dev-ruby/hoe-2.12 )"
+
+all_ruby_prepare() {
+ # Not a real fix, but otherwise USE="doc" breaks and defaulte license is MIT
+ sed -i -e "/license/d" Rakefile || die
+}