summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-12-04 20:18:25 +0000
committerHans de Graaff <graaff@gentoo.org>2010-12-04 20:18:25 +0000
commit915f2cfe9c1ccfb5bcb0b16b56d302f5cf940132 (patch)
tree31d316d2b5a73b2e36252dd13472f8168c464277 /dev-ruby
parentVersion bump with bugfixes and translation updates, remove old and skip tests... (diff)
downloadgentoo-2-915f2cfe9c1ccfb5bcb0b16b56d302f5cf940132.tar.gz
gentoo-2-915f2cfe9c1ccfb5bcb0b16b56d302f5cf940132.tar.bz2
gentoo-2-915f2cfe9c1ccfb5bcb0b16b56d302f5cf940132.zip
Version bump for Rails 3.
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activerecord/ChangeLog8
-rw-r--r--dev-ruby/activerecord/activerecord-3.0.3.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index aca3044ef28a..fd419c97d02a 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.143 2010/10/25 02:48:10 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.144 2010/12/04 20:18:25 graaff Exp $
+
+*activerecord-3.0.3 (04 Dec 2010)
+
+ 04 Dec 2010; Hans de Graaff <graaff@gentoo.org>
+ +activerecord-3.0.3.ebuild:
+ Version bump for Rails 3.
25 Oct 2010; Jeroen Roovers <jer@gentoo.org> activerecord-2.3.10.ebuild:
Marked ~hppa (bug #322175).
diff --git a/dev-ruby/activerecord/activerecord-3.0.3.ebuild b/dev-ruby/activerecord/activerecord-3.0.3.ebuild
new file mode 100644
index 000000000000..dd132bd4372a
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-3.0.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.0.3.ebuild,v 1.1 2010/12/04 20:18:25 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+# this is not null so that the dependencies will actually be filled
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="mysql postgres sqlite3" #sqlite
+
+S="${WORKDIR}/rails-rails-*/activerecord"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}
+ >=dev-ruby/arel-2.0.2
+ >=dev-ruby/tzinfo-0.3.23
+ sqlite3? ( dev-ruby/sqlite3-ruby )
+ mysql? ( >=dev-ruby/mysql-ruby-2.7 )
+ postgres? ( dev-ruby/pg )"
+
+#ruby_add_rdepend sqlite ">=dev-ruby/sqlite-ruby-2.2.2"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/sqlite3-ruby
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ !dev-ruby/test-unit:2
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ if use sqlite3; then
+ ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
+ fi
+ ;;
+ esac
+}