summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-01-15 10:52:23 +0000
committerHans de Graaff <graaff@gentoo.org>2012-01-15 10:52:23 +0000
commit9002d51105809581a7267949c29d98768b71d4b3 (patch)
tree60f099cca31bd2d3d3eb962e462d5af96c8009b8 /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-9002d51105809581a7267949c29d98768b71d4b3.tar.gz
gentoo-2-9002d51105809581a7267949c29d98768b71d4b3.tar.bz2
gentoo-2-9002d51105809581a7267949c29d98768b71d4b3.zip
Version bump. No longer depends on ruby_parser.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/method_source/ChangeLog9
-rw-r--r--dev-ruby/method_source/method_source-0.7.0.ebuild29
2 files changed, 36 insertions, 2 deletions
diff --git a/dev-ruby/method_source/ChangeLog b/dev-ruby/method_source/ChangeLog
index b2f429142295..260f6e9520ac 100644
--- a/dev-ruby/method_source/ChangeLog
+++ b/dev-ruby/method_source/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/method_source
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/method_source/ChangeLog,v 1.4 2011/12/28 08:33:26 graaff Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/method_source/ChangeLog,v 1.5 2012/01/15 10:52:23 graaff Exp $
+
+*method_source-0.7.0 (15 Jan 2012)
+
+ 15 Jan 2012; Hans de Graaff <graaff@gentoo.org> +method_source-0.7.0.ebuild:
+ Version bump. No longer depends on ruby_parser.
28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -method_source-0.6.5.ebuild,
-method_source-0.6.6.ebuild:
diff --git a/dev-ruby/method_source/method_source-0.7.0.ebuild b/dev-ruby/method_source/method_source-0.7.0.ebuild
new file mode 100644
index 000000000000..e59c4f264e52
--- /dev/null
+++ b/dev-ruby/method_source/method_source-0.7.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/method_source/method_source-0.7.0.ebuild,v 1.1 2012/01/15 10:52:23 graaff Exp $
+
+EAPI=4
+# jruby crashes on parsing the metadata.
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+RUBY_FAKEGEM_GEMSPEC="method_source.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Retrieve the source code for a method."
+HOMEPAGE="http://github.com/banister/method_source"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+
+ruby_add_bdepend "test? ( >=dev-ruby/bacon-1.1.0 )"
+
+each_ruby_test() {
+ ${RUBY} -I. -S bacon -k test/test.rb || die "Tests failed."
+}