summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-02-15 16:54:42 +0000
committerHans de Graaff <graaff@gentoo.org>2010-02-15 16:54:42 +0000
commit8f0fbfb812505ec0da4acc9d56c87c12c957aec3 (patch)
tree2f5e3969732d4e2316b5106c930f43b1b6149d7a /dev-ruby
parentMask prerelease libdrm snapshot and depending xf86-video-nouveau (diff)
downloadgentoo-2-8f0fbfb812505ec0da4acc9d56c87c12c957aec3.tar.gz
gentoo-2-8f0fbfb812505ec0da4acc9d56c87c12c957aec3.tar.bz2
gentoo-2-8f0fbfb812505ec0da4acc9d56c87c12c957aec3.zip
Add src directory so the require paths so that the gem actually works.
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/log4r/ChangeLog7
-rw-r--r--dev-ruby/log4r/log4r-1.1.5-r1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-ruby/log4r/ChangeLog b/dev-ruby/log4r/ChangeLog
index eaa752d1d8ee..6d97bcf4e3e7 100644
--- a/dev-ruby/log4r/ChangeLog
+++ b/dev-ruby/log4r/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/log4r
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/log4r/ChangeLog,v 1.14 2010/02/09 17:37:34 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/log4r/ChangeLog,v 1.15 2010/02/15 16:54:42 graaff Exp $
+
+*log4r-1.1.5-r1 (15 Feb 2010)
+
+ 15 Feb 2010; Hans de Graaff <graaff@gentoo.org> +log4r-1.1.5-r1.ebuild:
+ Add src directory so the require paths so that the gem actually works.
*log4r-1.1.5 (09 Feb 2010)
diff --git a/dev-ruby/log4r/log4r-1.1.5-r1.ebuild b/dev-ruby/log4r/log4r-1.1.5-r1.ebuild
new file mode 100644
index 000000000000..c9a96abaa113
--- /dev/null
+++ b/dev-ruby/log4r/log4r-1.1.5-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/log4r/log4r-1.1.5-r1.ebuild,v 1.1 2010/02/15 16:54:42 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+# There are no working tests atm, to be checked on next version bump.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README TODO"
+
+RUBY_FAKEGEM_EXTRAINSTALL="src"
+RUBY_FAKEGEM_REQUIRE_PATHS="src"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Log4r is a comprehensive and flexible logging library written in
+Ruby for use in Ruby programs."
+HOMEPAGE="http://log4r.sourceforge.net/"
+IUSE=""
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/* || die
+}