summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-05-18 06:54:13 +0000
committerHans de Graaff <graaff@gentoo.org>2012-05-18 06:54:13 +0000
commit85e79c6ee0ee845e6b0ed98574d8823b382abfad (patch)
treec96425636f1302f22fe306ba0fa174409933eda5 /dev-ruby
parentMarked ~ppc ~ppc64 for bug #402989. (diff)
downloadgentoo-2-85e79c6ee0ee845e6b0ed98574d8823b382abfad.tar.gz
gentoo-2-85e79c6ee0ee845e6b0ed98574d8823b382abfad.tar.bz2
gentoo-2-85e79c6ee0ee845e6b0ed98574d8823b382abfad.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/patron/ChangeLog9
-rw-r--r--dev-ruby/patron/patron-0.4.18.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/dev-ruby/patron/ChangeLog b/dev-ruby/patron/ChangeLog
index fd314eedf0bd..1206214768a5 100644
--- a/dev-ruby/patron/ChangeLog
+++ b/dev-ruby/patron/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/patron
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/ChangeLog,v 1.21 2011/11/02 06:22:18 graaff Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/ChangeLog,v 1.22 2012/05/18 06:54:13 graaff Exp $
+
+*patron-0.4.18 (18 May 2012)
+
+ 18 May 2012; Hans de Graaff <graaff@gentoo.org> +patron-0.4.18.ebuild:
+ Version bump.
02 Nov 2011; Hans de Graaff <graaff@gentoo.org> patron-0.4.16.ebuild:
Add ruby19.
diff --git a/dev-ruby/patron/patron-0.4.18.ebuild b/dev-ruby/patron/patron-0.4.18.ebuild
new file mode 100644
index 000000000000..7b2cacfc9fac
--- /dev/null
+++ b/dev-ruby/patron/patron-0.4.18.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/patron-0.4.18.ebuild,v 1.1 2012/05/18 06:54:13 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_EXTRADOC="README.txt"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Patron is a Ruby HTTP client library based on libcurl."
+HOMEPAGE="http://toland.github.com/patron/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+#ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+DEPEND="${DEPEND} net-misc/curl"
+RDEPEND="${RDEPEND} net-misc/curl"
+
+# Tests require a live web service that is not included in the distribution.
+RESTRICT="test"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/patron extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/patron || die
+ cp ext/patron/session_ext$(get_modname) lib/patron/ || die "Unable to cp shared object file"
+}