summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-03-04 06:58:00 +0000
committerHans de Graaff <graaff@gentoo.org>2011-03-04 06:58:00 +0000
commit8578b5c191a5bf6261d1648b0182b143c8a9b4cc (patch)
treea7e951a9513c901b70e56ddd46ea27976b4e4407 /dev-ruby
parentVersion bump to new snapshot and remove old. Add nls and link USE flags, remo... (diff)
downloadgentoo-2-8578b5c191a5bf6261d1648b0182b143c8a9b4cc.tar.gz
gentoo-2-8578b5c191a5bf6261d1648b0182b143c8a9b4cc.tar.bz2
gentoo-2-8578b5c191a5bf6261d1648b0182b143c8a9b4cc.zip
Version bump.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/storable/ChangeLog7
-rw-r--r--dev-ruby/storable/storable-0.8.7.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-ruby/storable/ChangeLog b/dev-ruby/storable/ChangeLog
index a91877df7dd8..1dbc30f257f9 100644
--- a/dev-ruby/storable/ChangeLog
+++ b/dev-ruby/storable/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/storable
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/ChangeLog,v 1.16 2011/02/18 07:14:33 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/ChangeLog,v 1.17 2011/03/04 06:58:00 graaff Exp $
+
+*storable-0.8.7 (04 Mar 2011)
+
+ 04 Mar 2011; Hans de Graaff <graaff@gentoo.org> +storable-0.8.7.ebuild:
+ Version bump.
*storable-0.8.6 (18 Feb 2011)
diff --git a/dev-ruby/storable/storable-0.8.7.ebuild b/dev-ruby/storable/storable-0.8.7.ebuild
new file mode 100644
index 000000000000..e16758c885cb
--- /dev/null
+++ b/dev-ruby/storable/storable-0.8.7.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/storable-0.8.7.ebuild,v 1.1 2011/03/04 06:58:00 graaff Exp $
+
+EAPI=2
+
+# jruby → yajl-ruby won't work, as it's compiled extension
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Marshal Ruby classes into and out of multiple formats"
+HOMEPAGE="http://solutious.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+SRC_URI="http://github.com/delano/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
+S="${WORKDIR}/delano-${PN}-*"
+
+# technically, it could work without either; on the other hand, it
+# would break a bit of stuff.
+#ruby_add_rdepend "|| ( dev-ruby/json dev-ruby/yajl-ruby )"
+
+# Somehow it infinite-recurse if JSON is used, see issue #1, so use
+# yajl directly.
+ruby_add_rdepend dev-ruby/yajl-ruby
+
+ruby_add_bdepend "test? ( dev-ruby/tryouts:2 )"
+
+all_ruby_prepare() {
+ mv bin examples || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S try || die "tests failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/* || die
+}