summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-08-25 14:25:07 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-08-25 14:25:07 +0000
commit84f317f5b774af5ee626c91477d1178b1ad3e342 (patch)
treefe3fcc254f55c1cab283bb757f045ca383b830d9 /dev-ruby
parentCleanup old. (diff)
downloadgentoo-2-84f317f5b774af5ee626c91477d1178b1ad3e342.tar.gz
gentoo-2-84f317f5b774af5ee626c91477d1178b1ad3e342.tar.bz2
gentoo-2-84f317f5b774af5ee626c91477d1178b1ad3e342.zip
Add ruby20, ruby21 support.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/png/ChangeLog7
-rw-r--r--dev-ruby/png/png-1.2.0-r2.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ruby/png/ChangeLog b/dev-ruby/png/ChangeLog
index 449d0a123242..eef8f1ac3642 100644
--- a/dev-ruby/png/ChangeLog
+++ b/dev-ruby/png/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/png
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/png/ChangeLog,v 1.13 2014/08/02 01:51:14 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/png/ChangeLog,v 1.14 2014/08/25 14:25:07 mrueg Exp $
+
+*png-1.2.0-r2 (25 Aug 2014)
+
+ 25 Aug 2014; Manuel Rüger <mrueg@gentoo.org> +png-1.2.0-r2.ebuild:
+ Add ruby20, ruby21 support.
02 Aug 2014; Manuel Rüger <mrueg@gentoo.org> png-1.2.0-r1.ebuild:
Fix build.
diff --git a/dev-ruby/png/png-1.2.0-r2.ebuild b/dev-ruby/png/png-1.2.0-r2.ebuild
new file mode 100644
index 000000000000..012514cbae7b
--- /dev/null
+++ b/dev-ruby/png/png-1.2.0-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/png/png-1.2.0-r2.ebuild,v 1.1 2014/08/25 14:25:07 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An almost pure-Ruby Portable Network Graphics (PNG) library"
+HOMEPAGE="http://rubyforge.org/projects/seattlerb/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/hoe )
+ test? (
+ dev-ruby/hoe
+ dev-ruby/minitest
+ )"
+
+ruby_add_rdepend ">=dev-ruby/RubyInline-3.5.0"
+
+all_ruby_prepare() {
+ sed -i -e "/rubyforge/s/^/#/" Rakefile || die
+ sed -i -e "1i# encoding: ascii-8bit" test/test_png.rb || die
+}
+
+src_test() {
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home."
+ ruby-ng_src_test
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r example
+}