summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-08-07 04:45:11 +0000
committerHans de Graaff <graaff@gentoo.org>2015-08-07 04:45:11 +0000
commit83a73463402bf493717de743e7f1a3d56196fc39 (patch)
tree18463ceb3dcc4de61c77ce87e5d337a9e0e8018e /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-83a73463402bf493717de743e7f1a3d56196fc39.tar.gz
gentoo-2-83a73463402bf493717de743e7f1a3d56196fc39.tar.bz2
gentoo-2-83a73463402bf493717de743e7f1a3d56196fc39.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby_parser/ChangeLog7
-rw-r--r--dev-ruby/ruby_parser/ruby_parser-3.7.1.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-ruby/ruby_parser/ChangeLog b/dev-ruby/ruby_parser/ChangeLog
index b46b3f21bede..e6b8cdb12e34 100644
--- a/dev-ruby/ruby_parser/ChangeLog
+++ b/dev-ruby/ruby_parser/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ruby_parser
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_parser/ChangeLog,v 1.82 2015/07/30 15:16:51 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_parser/ChangeLog,v 1.83 2015/08/07 04:45:11 graaff Exp $
+
+*ruby_parser-3.7.1 (07 Aug 2015)
+
+ 07 Aug 2015; Hans de Graaff <graaff@gentoo.org> +ruby_parser-3.7.1.ebuild:
+ Version bump.
30 Jul 2015; Agostino Sarubbo <ago@gentoo.org> ruby_parser-3.6.6.ebuild:
Stable for sparc, wrt bug #552244
diff --git a/dev-ruby/ruby_parser/ruby_parser-3.7.1.ebuild b/dev-ruby/ruby_parser/ruby_parser-3.7.1.ebuild
new file mode 100644
index 000000000000..39e5058e09cb
--- /dev/null
+++ b/dev-ruby/ruby_parser/ruby_parser-3.7.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_parser/ruby_parser-3.7.1.ebuild,v 1.1 2015/08/07 04:45:11 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby parser written in pure ruby"
+HOMEPAGE="https://github.com/seattlerb/ruby_parser"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/sexp_processor-4.6.0:4
+ !<dev-ruby/ruby_parser-2.3.1-r1"
+
+ruby_add_bdepend "doc? ( >=dev-ruby/hoe-2.9.1 )"
+ruby_add_bdepend "test? ( dev-ruby/racc >=dev-ruby/minitest-4.3 )"
+
+DEPEND+=" test? ( dev-util/unifdef )"
+
+all_ruby_prepare() {
+ # Remove reference to perforce method that is not in a released
+ # version of hoe-seattlerb.
+ #sed -i -e '/perforce/d' Rakefile || die
+ sed -i -e '/license/d' Rakefile || die
+ sed -i -e '/Hoe.plugin :isolate/ s:^:#:' Rakefile || die
+}