summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-11-12 19:54:35 +0000
committerHans de Graaff <graaff@gentoo.org>2012-11-12 19:54:35 +0000
commit8331ff418bcdb3876b76ed33e95721f493e059ab (patch)
treea5a8d74d2fec0e442b3137fc6ecc82a62dc4a092 /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-8331ff418bcdb3876b76ed33e95721f493e059ab.tar.gz
gentoo-2-8331ff418bcdb3876b76ed33e95721f493e059ab.tar.bz2
gentoo-2-8331ff418bcdb3876b76ed33e95721f493e059ab.zip
Version bump.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actionpack/ChangeLog7
-rw-r--r--dev-ruby/actionpack/actionpack-3.2.9.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index a86fc4b6d4f2..8d0b207a035a 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.217 2012/08/27 18:17:50 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.218 2012/11/12 19:54:35 graaff Exp $
+
+*actionpack-3.2.9 (12 Nov 2012)
+
+ 12 Nov 2012; Hans de Graaff <graaff@gentoo.org> +actionpack-3.2.9.ebuild:
+ Version bump.
27 Aug 2012; Hans de Graaff <graaff@gentoo.org> -actionpack-3.0.16.ebuild,
-actionpack-3.1.7.ebuild, -actionpack-3.2.7.ebuild:
diff --git a/dev-ruby/actionpack/actionpack-3.2.9.ebuild b/dev-ruby/actionpack/actionpack-3.2.9.ebuild
new file mode 100644
index 000000000000..d9e5da98730b
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-3.2.9.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-3.2.9.ebuild,v 1.1 2012/11/12 19:54:35 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+# The default test task tries to test activerecord with SQLite as well.
+RUBY_FAKEGEM_TASK_TEST="test_action_pack"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/actionpack"
+
+ruby_add_rdepend "
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/rack-cache-1.2
+ >=dev-ruby/builder-3.0.0:3
+ >=dev-ruby/erubis-2.7.0
+ >=dev-ruby/i18n-0.6:0.6
+ >=dev-ruby/rack-1.4.0:1.4
+ >=dev-ruby/rack-test-0.6.1:0.6
+ >=dev-ruby/journey-1.0.4:1.0
+ >=dev-ruby/sprockets-2.2.1:2.2"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.12.1
+ dev-ruby/bundler
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ >=dev-ruby/tzinfo-0.3.29
+ >=dev-ruby/uglifier-1.0.3
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\)/d" ../Gemfile || die
+
+ sed -i -e '/rack-ssl/d' ../railties/railties.gemspec || die
+ sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
+
+ # Avoid fragile tests depending on hash ordering
+ sed -i -e '/cookie_3=chocolate/ s:^:#:' test/controller/integration_test.rb || die
+ sed -i -e '/test_to_s/,/end/ s:^:#:' test/template/html-scanner/tag_node_test.rb || die
+ sed -i -e '/"name":"david"/ s:^:#:' test/controller/mime_responds_test.rb || die
+ sed -i -e '/test_option_html_attributes_with_multiple_element_hash/, / end/ s:^:#:' test/template/form_options_helper_test.rb || die
+ sed -i -e '/test_option_html_attributes_with_multiple_hashes/, / end/ s:^:#:' test/template/form_options_helper_test.rb || die
+}