summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-08-08 06:25:21 +0000
committerHans de Graaff <graaff@gentoo.org>2014-08-08 06:25:21 +0000
commit7e75026dc52285f5d7d21969b38b49d1e4f6a0f4 (patch)
treecae732dc5e3068718dde2e204502c7687bcfb347 /dev-ruby
parentBeta channel bump. (diff)
downloadgentoo-2-7e75026dc52285f5d7d21969b38b49d1e4f6a0f4.tar.gz
gentoo-2-7e75026dc52285f5d7d21969b38b49d1e4f6a0f4.tar.bz2
gentoo-2-7e75026dc52285f5d7d21969b38b49d1e4f6a0f4.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/http/ChangeLog7
-rw-r--r--dev-ruby/http/http-0.6.2.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-ruby/http/ChangeLog b/dev-ruby/http/ChangeLog
index 4f3aaf1f5610..209b786382fc 100644
--- a/dev-ruby/http/ChangeLog
+++ b/dev-ruby/http/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/http
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/http/ChangeLog,v 1.6 2014/08/05 16:00:49 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/http/ChangeLog,v 1.7 2014/08/08 06:25:21 graaff Exp $
+
+*http-0.6.2 (08 Aug 2014)
+
+ 08 Aug 2014; Hans de Graaff <graaff@gentoo.org> +http-0.6.2.ebuild:
+ Version bump.
05 Aug 2014; Manuel Rüger <mrueg@gentoo.org> http-0.5.0.ebuild:
Remove trailing '.' from DESCRIPTION.
diff --git a/dev-ruby/http/http-0.6.2.ebuild b/dev-ruby/http/http-0.6.2.ebuild
new file mode 100644
index 000000000000..9b3bad5a2fb2
--- /dev/null
+++ b/dev-ruby/http/http-0.6.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/http/http-0.6.2.ebuild,v 1.1 2014/08/08 06:25:21 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An easy-to-use client library for making requests from Ruby"
+HOMEPAGE="https://github.com/tarcieri/http"
+
+LICENSE="MIT"
+SLOT="0.6"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/http_parser_rb-0.6.0 =dev-ruby/http_parser_rb-0.6*"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/end/ s:^:#:' \
+ -e '1irequire "cgi"' spec/spec_helper.rb || die
+}