summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-04-20 07:28:46 +0000
committerHans de Graaff <graaff@gentoo.org>2012-04-20 07:28:46 +0000
commit7c456d614d73a911fffd713162c406617a3f098e (patch)
treee51aba1afa6e808f9580bad56590a093fc5984b1 /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-7c456d614d73a911fffd713162c406617a3f098e.tar.gz
gentoo-2-7c456d614d73a911fffd713162c406617a3f098e.tar.bz2
gentoo-2-7c456d614d73a911fffd713162c406617a3f098e.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actionmailer/ChangeLog7
-rw-r--r--dev-ruby/actionmailer/actionmailer-3.2.3.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index b7864d7e750f..9c5202557326 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.183 2012/04/05 17:12:52 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.184 2012/04/20 07:28:46 graaff Exp $
+
+*actionmailer-3.2.3 (20 Apr 2012)
+
+ 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +actionmailer-3.2.3.ebuild:
+ Version bump.
*actionmailer-3.1.4-r1 (05 Apr 2012)
diff --git a/dev-ruby/actionmailer/actionmailer-3.2.3.ebuild b/dev-ruby/actionmailer/actionmailer-3.2.3.ebuild
new file mode 100644
index 000000000000..2faec18b1f04
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-3.2.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-3.2.3.ebuild,v 1.1 2012/04/20 07:28:46 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/actionmailer"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.4.4"
+ruby_add_bdepend "test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+}