summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-12-08 19:38:36 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-12-08 19:38:36 +0000
commit7c39ba08d7acb72aaafcc0e96992b7f5ba9e2a62 (patch)
treef1444b819be39811cb4a2271210a399f61579718 /dev-ruby
parentAdd missing virtual/ruby-test-unit dependency to stay on the safe side; fix t... (diff)
downloadgentoo-2-7c39ba08d7acb72aaafcc0e96992b7f5ba9e2a62.tar.gz
gentoo-2-7c39ba08d7acb72aaafcc0e96992b7f5ba9e2a62.tar.bz2
gentoo-2-7c39ba08d7acb72aaafcc0e96992b7f5ba9e2a62.zip
Fix specifications so that they can be used with bundler (required for radiant-1). Also add mocha to the list of test dependencies for 3.0, found while installing the wrong slot.
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activesupport/ChangeLog11
-rw-r--r--dev-ruby/activesupport/activesupport-2.3.14-r1.ebuild43
-rw-r--r--dev-ruby/activesupport/activesupport-3.0.11.ebuild4
-rw-r--r--dev-ruby/activesupport/files/activesupport-2.3.14-unvendorize.patch96
4 files changed, 151 insertions, 3 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 24fd9e4e84dd..e56b1e131418 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.157 2011/11/19 10:53:57 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.158 2011/12/08 19:38:36 flameeyes Exp $
+
+*activesupport-2.3.14-r1 (08 Dec 2011)
+
+ 08 Dec 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ +activesupport-2.3.14-r1.ebuild,
+ +files/activesupport-2.3.14-unvendorize.patch, activesupport-3.0.11.ebuild:
+ Fix specifications so that they can be used with bundler (required for
+ radiant-1). Also add mocha to the list of test dependencies for 3.0, found
+ while installing the wrong slot.
*activesupport-3.0.11 (19 Nov 2011)
diff --git a/dev-ruby/activesupport/activesupport-2.3.14-r1.ebuild b/dev-ruby/activesupport/activesupport-2.3.14-r1.ebuild
new file mode 100644
index 000000000000..a0de5bae5292
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-2.3.14-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-2.3.14-r1.ebuild,v 1.1 2011/12/08 19:38:36 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/builder-2.1.2:0 >=dev-ruby/tzinfo-0.3.16 >=dev-ruby/i18n-0.4.1:0.4"
+
+all_ruby_prepare() {
+ # Remove the bundled packages!
+ rm -r lib/active_support/vendor/{tzinfo,builder,i18n}-* \
+ || die "failed to remove vendor packages"
+
+ # This patch removes the fallback to local vendorized gems, as well
+ # as fixing the dependencies for i18n to use the correct slot. It
+ # also edits the metadata file so that the dependencies are added to
+ # the specification, which is required for bundler to pick them up
+ # (which in turn is required by radiant 1.0.0rc3 to
+ # work). Furthermore remove the references to the vendorized copies
+ # from the specification, to be safe.
+ epatch "${FILESDIR}"/${PN}-2.3.14-unvendorize.patch
+ sed -i -e '/\/vendor\//d' ../metadata
+
+ # don't support older mocha versions as the optional codepath
+ # breaks JRuby
+ epatch "${FILESDIR}"/${PN}-2.3.5-mocha-0.9.5.patch
+}
diff --git a/dev-ruby/activesupport/activesupport-3.0.11.ebuild b/dev-ruby/activesupport/activesupport-3.0.11.ebuild
index 8ec9762babf4..7ff0cd4b3a6f 100644
--- a/dev-ruby/activesupport/activesupport-3.0.11.ebuild
+++ b/dev-ruby/activesupport/activesupport-3.0.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.0.11.ebuild,v 1.1 2011/11/19 10:53:57 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.0.11.ebuild,v 1.2 2011/12/08 19:38:36 flameeyes Exp $
EAPI=4
@@ -30,7 +30,7 @@ ruby_add_rdepend ">=dev-ruby/memcache-client-1.5.8"
# libxml-ruby and nokogiri are not strictly needed, but there are tests
# using this code.
-ruby_add_bdepend "test? ( virtual/ruby-test-unit >=dev-ruby/libxml-2.0.0 dev-ruby/nokogiri )"
+ruby_add_bdepend "test? ( virtual/ruby-test-unit >=dev-ruby/libxml-2.0.0 dev-ruby/nokogiri dev-ruby/mocha )"
all_ruby_prepare() {
# don't support older mocha versions as the optional codepath
diff --git a/dev-ruby/activesupport/files/activesupport-2.3.14-unvendorize.patch b/dev-ruby/activesupport/files/activesupport-2.3.14-unvendorize.patch
new file mode 100644
index 000000000000..d84f286261c1
--- /dev/null
+++ b/dev-ruby/activesupport/files/activesupport-2.3.14-unvendorize.patch
@@ -0,0 +1,96 @@
+Index: activesupport-2.3.5/lib/active_support/vendor.rb
+===================================================================
+--- activesupport-2.3.5.orig/lib/active_support/vendor.rb
++++ activesupport-2.3.5/lib/active_support/vendor.rb
+@@ -1,11 +1,7 @@
+ # Prefer gems to the bundled libs.
+ require 'rubygems'
+
+-begin
+- gem 'builder', '~> 2.1.2'
+-rescue Gem::LoadError
+- $:.unshift "#{File.dirname(__FILE__)}/vendor/builder-2.1.2"
+-end
++gem 'builder', '~> 2.1.2'
+ require 'builder'
+
+ begin
+@@ -14,15 +10,7 @@ rescue Gem::LoadError
+ $:.unshift "#{File.dirname(__FILE__)}/vendor/memcache-client-1.7.4"
+ end
+
+-begin
+- gem 'tzinfo', '~> 0.3.12'
+-rescue Gem::LoadError
+- $:.unshift "#{File.dirname(__FILE__)}/vendor/tzinfo-0.3.12"
+-end
++gem 'tzinfo', '~> 0.3.12'
+
+-begin
+- gem 'i18n', '>= 0.4.1'
+-rescue Gem::LoadError
+- $:.unshift "#{File.dirname(__FILE__)}/vendor/i18n-0.4.1"
+-end
++gem 'i18n', '~> 0.4.1'
+ require 'i18n'
+Index: metadata
+===================================================================
+--- a/../metadata
++++ b/../metadata
+@@ -16,7 +16,55 @@ bindir: bin
+ cert_chain: []
+
+ date: 2011-08-16 00:00:00 Z
+-dependencies: []
++dependencies:
++- !ruby/object:Gem::Dependency
++ name: builder
++ prerelease: false
++ requirement: &id001 !ruby/object:Gem::Requirement
++ none: false
++ requirements:
++ - - "~>"
++ - !ruby/object:Gem::Version
++ hash: 57
++ segments:
++ - 2
++ - 1
++ - 2
++ version: 2.1.2
++ type: :runtime
++ version_requirements: *id003
++- !ruby/object:Gem::Dependency
++ name: tzinfo
++ prerelease: false
++ requirement: &id002 !ruby/object:Gem::Requirement
++ none: false
++ requirements:
++ - - ">="
++ - !ruby/object:Gem::Version
++ hash: 57
++ segments:
++ - 0
++ - 3
++ - 16
++ version: 0.3.16
++ type: :runtime
++ version_requirements: *id003
++- !ruby/object:Gem::Dependency
++ name: i18n
++ prerelease: false
++ requirement: &id003 !ruby/object:Gem::Requirement
++ none: false
++ requirements:
++ - - "~>"
++ - !ruby/object:Gem::Version
++ hash: 57
++ segments:
++ - 0
++ - 4
++ - 1
++ version: 0.4.1
++ type: :runtime
++ version_requirements: *id003
+
+ description: Utility library which carries commonly used classes and goodies from the Rails framework
+ email: david@loudthinking.com