summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-10-17 06:35:02 +0000
committerHans de Graaff <graaff@gentoo.org>2013-10-17 06:35:02 +0000
commit7978876788604520b52b77086bf7d7258c1a4189 (patch)
tree37fe4f7ac4ad7ebd2cd89138a4ee73fc14634f5a /dev-ruby
parentVersion bump for security bug 488298. (diff)
downloadgentoo-2-7978876788604520b52b77086bf7d7258c1a4189.tar.gz
gentoo-2-7978876788604520b52b77086bf7d7258c1a4189.tar.bz2
gentoo-2-7978876788604520b52b77086bf7d7258c1a4189.zip
Version bump for security bug 488298.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activeresource/ChangeLog8
-rw-r--r--dev-ruby/activeresource/activeresource-3.2.15.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-ruby/activeresource/ChangeLog b/dev-ruby/activeresource/ChangeLog
index 1c9522e9665c..6fc6bad0d424 100644
--- a/dev-ruby/activeresource/ChangeLog
+++ b/dev-ruby/activeresource/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activeresource
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.160 2013/08/17 10:31:25 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.161 2013/10/17 06:35:02 graaff Exp $
+
+*activeresource-3.2.15 (17 Oct 2013)
+
+ 17 Oct 2013; Hans de Graaff <graaff@gentoo.org>
+ +activeresource-3.2.15.ebuild:
+ Version bump for security bug 488298.
*activeresource-3.2.14 (17 Aug 2013)
diff --git a/dev-ruby/activeresource/activeresource-3.2.15.ebuild b/dev-ruby/activeresource/activeresource-3.2.15.ebuild
new file mode 100644
index 000000000000..bb5e5ba188b8
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-3.2.15.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-3.2.15.ebuild,v 1.1 2013/10/17 06:35:02 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activeresource.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ dev-ruby/builder:3"
+ruby_add_bdepend "
+ test? (
+ dev-ruby/test-unit:2
+ >=dev-ruby/mocha-0.13.0:0.13
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Make sure we use the test-unit gem since ruby18 does not provide
+ # all the test-unit features needed.
+ sed -i -e '1igem "test-unit"' test/abstract_unit.rb || die
+}