summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2007-12-29 14:43:56 +0000
committerHans de Graaff <graaff@gentoo.org>2007-12-29 14:43:56 +0000
commit78593aa9e0afa11714aed083c2bea1a27c48861e (patch)
treebe568752e1df9973329f109ca383d2ebdea0975d /dev-ruby
parentAdd 0.4.5. (diff)
downloadgentoo-2-78593aa9e0afa11714aed083c2bea1a27c48861e.tar.gz
gentoo-2-78593aa9e0afa11714aed083c2bea1a27c48861e.tar.bz2
gentoo-2-78593aa9e0afa11714aed083c2bea1a27c48861e.zip
Version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rmagick/ChangeLog10
-rw-r--r--dev-ruby/rmagick/files/digest-rmagick-2.0.03
-rw-r--r--dev-ruby/rmagick/rmagick-2.0.0.ebuild66
3 files changed, 78 insertions, 1 deletions
diff --git a/dev-ruby/rmagick/ChangeLog b/dev-ruby/rmagick/ChangeLog
index f13bd18456fb..f1557dff3a80 100644
--- a/dev-ruby/rmagick/ChangeLog
+++ b/dev-ruby/rmagick/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/rmagick
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.86 2007/12/27 08:09:44 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.87 2007/12/29 14:43:55 graaff Exp $
+
+*rmagick-2.0.0 (29 Dec 2007)
+
+ 29 Dec 2007; Hans de Graaff <graaff@gentoo.org> +rmagick-2.0.0.ebuild:
+ Version bump:
+ * A lot of changes to support newer versions of ImageMagick better
+ * Ruby 1.9.0 comptability fixes
+ * Many new methods added and old methods deprecated
*rmagick-1.15.12 (27 Dec 2007)
diff --git a/dev-ruby/rmagick/files/digest-rmagick-2.0.0 b/dev-ruby/rmagick/files/digest-rmagick-2.0.0
new file mode 100644
index 000000000000..5d0887259637
--- /dev/null
+++ b/dev-ruby/rmagick/files/digest-rmagick-2.0.0
@@ -0,0 +1,3 @@
+MD5 225472f1de817095a0b73a137e7175c3 RMagick-2.0.0.tar.bz2 928741
+RMD160 769abf5e6200e1d26d8a2bc4127d15fc08b72f9d RMagick-2.0.0.tar.bz2 928741
+SHA256 39e3ca177b85986e5d9d19b6f6af9e24ff189976eb2ea83f3232f3a8d347a7e8 RMagick-2.0.0.tar.bz2 928741
diff --git a/dev-ruby/rmagick/rmagick-2.0.0.ebuild b/dev-ruby/rmagick/rmagick-2.0.0.ebuild
new file mode 100644
index 000000000000..377acc3db1a0
--- /dev/null
+++ b/dev-ruby/rmagick/rmagick-2.0.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/rmagick-2.0.0.ebuild,v 1.1 2007/12/29 14:43:55 graaff Exp $
+
+inherit ruby
+
+# The gem for this package doesn't seem to play well with portage. It
+# runs a GNUish configure script, with argument passed directly from
+# the gem install command, but gem install doesn't use the same style
+# of arguments. Thus, unless you're smart enough to come up with a
+# fix, please leave this as a source package install.
+
+MY_PV=${PV//_/-}
+DESCRIPTION="An interface between Ruby and the ImageMagick(TM) image processing library"
+HOMEPAGE="http://rmagick.rubyforge.org/"
+SRC_URI="http://rubyforge.org/frs/download.php/29809/RMagick-${MY_PV}.tar.bz2"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples doc"
+DEPEND="virtual/ruby
+ >=media-gfx/imagemagick-6.3.5.6"
+
+S=${WORKDIR}/RMagick-2.0.0
+
+# hdri causes extensive changes in the imagemagick internals, and
+# rmagick is not ready to deal with those, see bug 184356.
+pkg_setup() {
+ if built_with_use --missing false media-gfx/imagemagick hdri ; then
+ eerror "imagemagick is built with the hdri USE flag, this is not supported by rmagick"
+ eerror "please rebuild imagemagick without hdri support if you want to use rmagick"
+ die "imagemagick is built with the hdri USE flag, this is not supported by rmagick"
+ fi
+}
+
+# Use a custom src_compile because the setup.rb included with RMagick
+# doesn't like extra parameters during the setup phase.
+src_compile() {
+ # When documentation is built many examples are also run. Not all
+ # of them may work (e.g. due to missing additional dependencies)
+ # so we allow the examples to fail.
+ if ! use doc ; then
+ RUBY_ECONF="--disable-htmldoc --allow-example-errors"
+ fi
+
+ ${RUBY} setup.rb config --prefix=/usr "$@" \
+ ${RUBY_ECONF} ${EXTRA_ECONF} || die "setup.rb config failed"
+ ${RUBY} setup.rb setup || die "setup.rb setup failed"
+}
+
+# Use a custom src_install instead of the default one in ruby.eclass
+# because the one in ruby.eclass does not include setting the prefix
+# for the installation step and assumes that arguments can be given
+# also during the install phase.
+src_install() {
+ if ! use doc ; then
+ RUBY_ECONF="--disable-htmldoc --allow-example-errors"
+ fi
+
+ ${RUBY} setup.rb config --prefix="${D}/usr" "$@" \
+ ${RUBY_ECONF} ${EXTRA_ECONF} || die "setup.rb config failed"
+ ${RUBY} setup.rb install --prefix="${D}" || die "setup.rb install failed"
+
+ cd "${S}"
+ dodoc ChangeLog README.html README-Mac-OSX.txt README.txt
+}