summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-03-30 13:17:30 +0000
committerHans de Graaff <graaff@gentoo.org>2013-03-30 13:17:30 +0000
commit73a06fa0ee816e9fbeaaacfeae4fec47d6ff5dc9 (patch)
tree3bace30496d4ab6e4d54fbbc0a67aafde2a665f7 /dev-ruby
parentVersion bump for security bug 462452. (diff)
downloadgentoo-2-73a06fa0ee816e9fbeaaacfeae4fec47d6ff5dc9.tar.gz
gentoo-2-73a06fa0ee816e9fbeaaacfeae4fec47d6ff5dc9.tar.bz2
gentoo-2-73a06fa0ee816e9fbeaaacfeae4fec47d6ff5dc9.zip
Version bump for security bug 462452.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actionmailer/ChangeLog7
-rw-r--r--dev-ruby/actionmailer/actionmailer-3.1.12.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index de77159f046d..2422c0f25e6b 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.232 2013/03/30 09:32:51 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.233 2013/03/30 13:17:30 graaff Exp $
+
+*actionmailer-3.1.12 (30 Mar 2013)
+
+ 30 Mar 2013; Hans de Graaff <graaff@gentoo.org> +actionmailer-3.1.12.ebuild:
+ Version bump for security bug 462452.
*actionmailer-2.3.18 (30 Mar 2013)
diff --git a/dev-ruby/actionmailer/actionmailer-3.1.12.ebuild b/dev-ruby/actionmailer/actionmailer-3.1.12.ebuild
new file mode 100644
index 000000000000..35a4d300bb1a
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-3.1.12.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-3.1.12.ebuild,v 1.1 2013/03/30 13:17:30 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.1"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/actionmailer"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.3.3:2.3"
+ruby_add_bdepend "test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ sed -i -e '/dependency.*mail/s:~>:>=:' "${RUBY_FAKEGEM_GEMSPEC}" || die
+}