summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2009-02-08 19:55:33 +0000
committerAlex Legler <a3li@gentoo.org>2009-02-08 19:55:33 +0000
commit7318c28eb6422eec433901e75543b0dfbd14bd17 (patch)
tree87d9345c9c7f1c247d2b20a62edf15271bea6dad /dev-ruby
parentFix linking order #248444 by Diego E. Pettenò. (diff)
downloadgentoo-2-7318c28eb6422eec433901e75543b0dfbd14bd17.tar.gz
gentoo-2-7318c28eb6422eec433901e75543b0dfbd14bd17.tar.bz2
gentoo-2-7318c28eb6422eec433901e75543b0dfbd14bd17.zip
Removing ruby16 and ruby19 from USE_RUBY, thus depending explicitly on 1.8
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-serialport/ChangeLog8
-rw-r--r--dev-ruby/ruby-serialport/ruby-serialport-0.6.ebuild15
2 files changed, 14 insertions, 9 deletions
diff --git a/dev-ruby/ruby-serialport/ChangeLog b/dev-ruby/ruby-serialport/ChangeLog
index beec581440de..7dfbf7cf2be8 100644
--- a/dev-ruby/ruby-serialport/ChangeLog
+++ b/dev-ruby/ruby-serialport/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/ruby-serialport
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-serialport/ChangeLog,v 1.7 2006/10/20 21:28:11 agriffis Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-serialport/ChangeLog,v 1.8 2009/02/08 19:55:33 a3li Exp $
+
+ 08 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-serialport-0.6.ebuild:
+ Removing ruby16 and ruby19 from USE_RUBY and depending explicitly on
+ ruby18
20 Oct 2006; Aron Griffis <agriffis@gentoo.org>
ruby-serialport-0.6.ebuild:
diff --git a/dev-ruby/ruby-serialport/ruby-serialport-0.6.ebuild b/dev-ruby/ruby-serialport/ruby-serialport-0.6.ebuild
index 09279528a2f3..918344d8acd1 100644
--- a/dev-ruby/ruby-serialport/ruby-serialport-0.6.ebuild
+++ b/dev-ruby/ruby-serialport/ruby-serialport-0.6.ebuild
@@ -1,26 +1,27 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-serialport/ruby-serialport-0.6.ebuild,v 1.8 2006/10/20 21:28:11 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-serialport/ruby-serialport-0.6.ebuild,v 1.9 2009/02/08 19:55:33 a3li Exp $
inherit ruby
DESCRIPTION="a library for serial port (rs232) access in ruby"
HOMEPAGE="http://rubyforge.org/projects/ruby-serialport/"
-SRC_URI="http://rubyforge.org/download.php/72/${P}.tar.gz"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="ia64 ~ppc x86"
IUSE=""
-USE_RUBY="ruby16 ruby18 ruby19"
-DEPEND="virtual/ruby"
+USE_RUBY="ruby18"
+DEPEND="=dev-lang/ruby-1.8*"
+RDEPEND="${DEPEND}"
src_compile() {
- ruby extconf.rb || die
+ ruby18 extconf.rb || die
emake || die
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
dodoc CHANGELOG README
docinto test
dodoc test/*