summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-06-19 17:34:01 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-06-19 17:34:01 +0000
commit705b960d608005bdc10876cf6b16995674e820e0 (patch)
treef97dc947c004e3a451be746c9b80806cb2b9f52a /dev-ruby
parentVersion bump, reduce patching to our tests' hacks. (diff)
downloadgentoo-2-705b960d608005bdc10876cf6b16995674e820e0.tar.gz
gentoo-2-705b960d608005bdc10876cf6b16995674e820e0.tar.bz2
gentoo-2-705b960d608005bdc10876cf6b16995674e820e0.zip
Version bump, remove patch.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/oauth2/ChangeLog10
-rw-r--r--dev-ruby/oauth2/files/oauth2-0.0.8-gentoo.patch31
-rw-r--r--dev-ruby/oauth2/files/oauth2-0.0.9-gentoo.patch65
-rw-r--r--dev-ruby/oauth2/oauth2-0.0.10.ebuild (renamed from dev-ruby/oauth2/oauth2-0.0.8.ebuild)8
-rw-r--r--dev-ruby/oauth2/oauth2-0.0.9.ebuild28
5 files changed, 11 insertions, 131 deletions
diff --git a/dev-ruby/oauth2/ChangeLog b/dev-ruby/oauth2/ChangeLog
index 3227e84cd7fd..34f0557d1260 100644
--- a/dev-ruby/oauth2/ChangeLog
+++ b/dev-ruby/oauth2/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/oauth2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/ChangeLog,v 1.5 2010/06/19 12:34:34 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/ChangeLog,v 1.6 2010/06/19 17:34:01 flameeyes Exp $
+
+*oauth2-0.0.10 (19 Jun 2010)
+
+ 19 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ -oauth2-0.0.8.ebuild, -files/oauth2-0.0.8-gentoo.patch,
+ -oauth2-0.0.9.ebuild, -files/oauth2-0.0.9-gentoo.patch,
+ +oauth2-0.0.10.ebuild:
+ Version bump, remove patch.
*oauth2-0.0.9 (19 Jun 2010)
diff --git a/dev-ruby/oauth2/files/oauth2-0.0.8-gentoo.patch b/dev-ruby/oauth2/files/oauth2-0.0.8-gentoo.patch
deleted file mode 100644
index 633338d8cb30..000000000000
--- a/dev-ruby/oauth2/files/oauth2-0.0.8-gentoo.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff --git a/Rakefile b/Rakefile
-index 0667c9c..0a135d5 100644
---- a/Rakefile
-+++ b/Rakefile
-@@ -15,10 +15,13 @@ begin
- # gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
- end
- Jeweler::GemcutterTasks.new
-+
-+ task :spec => :check_dependencies
- rescue LoadError
- puts "Jeweler (or a dependency) not available. Install it with: gem install jeweler"
- end
-
-+begin
- require 'spec/rake/spectask'
- Spec::Rake::SpecTask.new(:spec) do |spec|
- spec.libs << 'lib' << 'spec'
-@@ -31,9 +34,10 @@ Spec::Rake::SpecTask.new(:rcov) do |spec|
- spec.rcov = true
- end
-
--task :spec => :check_dependencies
--
- task :default => :spec
-+rescue LoadError
-+ puts "RSpec (or a dependency) not available. Install it with: gem install rspec"
-+end
-
- require 'rake/rdoctask'
- Rake::RDocTask.new do |rdoc|
diff --git a/dev-ruby/oauth2/files/oauth2-0.0.9-gentoo.patch b/dev-ruby/oauth2/files/oauth2-0.0.9-gentoo.patch
deleted file mode 100644
index fb27f0371530..000000000000
--- a/dev-ruby/oauth2/files/oauth2-0.0.9-gentoo.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-diff --git a/Rakefile b/Rakefile
-index e4b0361..983d568 100644
---- a/Rakefile
-+++ b/Rakefile
-@@ -16,10 +16,13 @@ begin
- # gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
- end
- Jeweler::GemcutterTasks.new
-+
-+ task :spec => :check_dependencies
- rescue LoadError
- puts "Jeweler (or a dependency) not available. Install it with: gem install jeweler"
- end
-
-+begin
- require 'spec/rake/spectask'
- Spec::Rake::SpecTask.new(:spec) do |spec|
- spec.libs << 'lib' << 'spec'
-@@ -32,9 +35,10 @@ Spec::Rake::SpecTask.new(:rcov) do |spec|
- spec.rcov = true
- end
-
--task :spec => :check_dependencies
--
- task :default => :spec
-+rescue LoadError
-+ puts "RSpec (or a dependency) not available. Install it with: gem install rspec"
-+end
-
- require 'rake/rdoctask'
- Rake::RDocTask.new do |rdoc|
-diff --git a/lib/oauth2/strategy/web_server.rb b/lib/oauth2/strategy/web_server.rb
-index f8aa562..25bd5a9 100644
---- a/lib/oauth2/strategy/web_server.rb
-+++ b/lib/oauth2/strategy/web_server.rb
-@@ -13,7 +13,14 @@ module OAuth2
- # endpoints.
- def get_access_token(code, options = {})
- response = @client.request(:post, @client.access_token_url, access_token_params(code, options))
-- params = MultiJson.decode(response) rescue Rack::Utils.parse_query(response)
-+
-+ params = MultiJson.decode(response) rescue nil
-+ # the ActiveSupport JSON parser won't cause an exception when
-+ # given a formencoded string, so make sure that it was
-+ # actually parsed in an Hash. This covers even the case where
-+ # it caused an exception since it'll still be nil.
-+ params = Rack::Utils.parse_query(response) unless params.is_a? Hash
-+
- access = params['access_token']
- refresh = params['refresh_token']
- expires_in = params['expires_in']
-diff --git a/spec/oauth2/strategy/web_server_spec.rb b/spec/oauth2/strategy/web_server_spec.rb
-index aee0b76..14c5008 100644
---- a/spec/oauth2/strategy/web_server_spec.rb
-+++ b/spec/oauth2/strategy/web_server_spec.rb
-@@ -34,8 +34,8 @@ describe OAuth2::Strategy::WebServer do
- end
- end
-
-- describe "#get_access_token" do
- %w(json formencoded).each do |mode|
-+ describe "#get_access_token (#{mode})" do
- before do
- @mode = mode
- @access = subject.get_access_token('sushi')
diff --git a/dev-ruby/oauth2/oauth2-0.0.8.ebuild b/dev-ruby/oauth2/oauth2-0.0.10.ebuild
index 2f353aea395a..ca1fee43ac62 100644
--- a/dev-ruby/oauth2/oauth2-0.0.8.ebuild
+++ b/dev-ruby/oauth2/oauth2-0.0.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/oauth2-0.0.8.ebuild,v 1.4 2010/05/18 18:45:34 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/oauth2-0.0.10.ebuild,v 1.1 2010/06/19 17:34:01 flameeyes Exp $
EAPI="2"
@@ -22,9 +22,5 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-ruby_add_rdepend "dev-ruby/faraday"
+ruby_add_rdepend "dev-ruby/faraday >=dev-ruby/multi_json-0.0.4"
ruby_add_bdepend test ">=dev-ruby/rspec-1.2.9"
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
-}
diff --git a/dev-ruby/oauth2/oauth2-0.0.9.ebuild b/dev-ruby/oauth2/oauth2-0.0.9.ebuild
deleted file mode 100644
index 3397f2dbc5d1..000000000000
--- a/dev-ruby/oauth2/oauth2-0.0.9.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/oauth2-0.0.9.ebuild,v 1.1 2010/06/19 12:34:34 flameeyes Exp $
-
-EAPI="2"
-
-USE_RUBY="ruby18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_TEST="spec"
-RUBY_FAKEGEM_TASK_DOC="rerdoc"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGELOG.rdoc"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth gem."
-HOMEPAGE="http://github.com/intridea/oauth2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-ruby_add_rdepend "dev-ruby/faraday >=dev-ruby/multi_json-0.0.3-r1"
-ruby_add_bdepend test ">=dev-ruby/rspec-1.2.9"
-
-RUBY_PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )