summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-04-20 06:28:20 +0000
committerHans de Graaff <graaff@gentoo.org>2010-04-20 06:28:20 +0000
commit6cea034bdfbe96f856f17fb925e1f75351c360bb (patch)
tree1e6b7b76b65fefb3c1617706f03f799db262ef0f /dev-ruby
parentThe 5.4 patchsets for HPN and LPK apply and work perfectly with 5.5. (diff)
downloadgentoo-2-6cea034bdfbe96f856f17fb925e1f75351c360bb.tar.gz
gentoo-2-6cea034bdfbe96f856f17fb925e1f75351c360bb.tar.bz2
gentoo-2-6cea034bdfbe96f856f17fb925e1f75351c360bb.zip
Version bump: Updated to tzdata version 2010i.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/tzinfo/ChangeLog7
-rw-r--r--dev-ruby/tzinfo/tzinfo-0.3.20.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-ruby/tzinfo/ChangeLog b/dev-ruby/tzinfo/ChangeLog
index a1998577efe5..c38962a07ed5 100644
--- a/dev-ruby/tzinfo/ChangeLog
+++ b/dev-ruby/tzinfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/tzinfo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.55 2010/04/18 17:33:37 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.56 2010/04/20 06:28:20 graaff Exp $
+
+*tzinfo-0.3.20 (20 Apr 2010)
+
+ 20 Apr 2010; Hans de Graaff <graaff@gentoo.org> +tzinfo-0.3.20.ebuild:
+ Version bump: Updated to tzdata version 2010i.
18 Apr 2010; <nixnut@gentoo.org> tzinfo-0.3.16.ebuild:
ppc stable #312963
diff --git a/dev-ruby/tzinfo/tzinfo-0.3.20.ebuild b/dev-ruby/tzinfo/tzinfo-0.3.20.ebuild
new file mode 100644
index 000000000000..456ea4023a1e
--- /dev/null
+++ b/dev-ruby/tzinfo/tzinfo-0.3.20.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/tzinfo-0.3.20.ebuild,v 1.1 2010/04/20 06:28:20 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Daylight-savings aware timezone library"
+HOMEPAGE="http://tzinfo.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+ruby_add_bdepend test virtual/ruby-test-unit
+
+all_ruby_prepare() {
+ # The package has all the files executable, probably coming from
+ # Windows.
+ find "${S}" -type f -perm +111 -exec chmod -x {} +
+
+ # With rubygems 1.3.1 we get the following warning
+ # warning: Insecure world writable dir /var/tmp in LOAD_PATH, mode 041777
+ # when running the test_get_tainted_not_loaded test.
+ sed -i -e '138,146s:^:#:' "${S}"/test/tc_timezone.rb || die "unable to sed out the test"
+}