summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2009-12-05 10:17:31 +0000
committerHans de Graaff <graaff@gentoo.org>2009-12-05 10:17:31 +0000
commit68dbf351b46de3aee5630efb8f1f5b812decc5e4 (patch)
treea2d71858257c05b0a0ade3d871ad4b3fef432b7b /dev-ruby
parentAdded static USE flag, bug #275460, thank Joakim Tjernlund for report. Drop old. (diff)
downloadgentoo-2-68dbf351b46de3aee5630efb8f1f5b812decc5e4.tar.gz
gentoo-2-68dbf351b46de3aee5630efb8f1f5b812decc5e4.tar.bz2
gentoo-2-68dbf351b46de3aee5630efb8f1f5b812decc5e4.zip
Switch to ruby-ng to fix #282430.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rmagick/ChangeLog9
-rw-r--r--dev-ruby/rmagick/rmagick-2.12.2-r1.ebuild71
2 files changed, 79 insertions, 1 deletions
diff --git a/dev-ruby/rmagick/ChangeLog b/dev-ruby/rmagick/ChangeLog
index 10f68231b45e..e9414264a2d4 100644
--- a/dev-ruby/rmagick/ChangeLog
+++ b/dev-ruby/rmagick/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/rmagick
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.156 2009/11/14 15:24:53 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.157 2009/12/05 10:17:31 graaff Exp $
+
+*rmagick-2.12.2-r1 (05 Dec 2009)
+
+ 05 Dec 2009; Hans de Graaff <graaff@gentoo.org> +rmagick-2.12.2-r1.ebuild:
+ Use ruby-ng eclass so that rmagick can be installed for multiple ruby
+ targets. Fixes #282430 in principle but not in practice because no
+ other ruby targets match rmagick's keywords. Moved here from ruby-ng-testbed.
14 Nov 2009; Raúl Porcel <armin76@gentoo.org> rmagick-2.11.0.ebuild:
ia64/sparc stable wrt #287812
diff --git a/dev-ruby/rmagick/rmagick-2.12.2-r1.ebuild b/dev-ruby/rmagick/rmagick-2.12.2-r1.ebuild
new file mode 100644
index 000000000000..77d52f69530e
--- /dev/null
+++ b/dev-ruby/rmagick/rmagick-2.12.2-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/rmagick-2.12.2-r1.ebuild,v 1.1 2009/12/05 10:17:31 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+inherit ruby-ng
+
+# The gem for this package doesn't seem to play well with portage. It
+# runs a GNUish configure script, with argument passed directly from
+# the gem install command, but gem install doesn't use the same style
+# of arguments. Thus, unless you're smart enough to come up with a
+# fix, please leave this as a source package install.
+
+MY_PV=${PV//_/-}
+
+DESCRIPTION="An interface between Ruby and the ImageMagick(TM) image processing library"
+HOMEPAGE="http://rmagick.rubyforge.org/"
+SRC_URI="mirror://rubyforge/rmagick/RMagick-${MY_PV}.tar.bz2"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples doc"
+
+# hdri causes extensive changes in the imagemagick internals, and
+# rmagick is not ready to deal with those, see bug 184356.
+RDEPEND="virtual/ruby
+ >=media-gfx/imagemagick-6.3.5.10[-hdri]"
+DEPEND="${RDEPEND}
+ doc? ( virtual/ghostscript media-libs/libwmf )"
+
+S="${WORKDIR}/RMagick-${PV}"
+
+each_ruby_compile() {
+ local myconf
+
+ # When documentation is built many examples are also run. Not all
+ # of them may work (e.g. due to missing additional dependencies)
+ # so we allow the examples to fail.
+ if ! use doc ; then
+ myconf="--disable-htmldoc --allow-example-errors"
+ fi
+
+ ${RUBY} setup.rb config --prefix=/usr "$@" \
+ ${myconf} || die "setup.rb config failed"
+ ${RUBY} setup.rb setup || die "setup.rb setup failed"
+}
+
+# Use a custom src_install instead of the default one in ruby.eclass
+# because the one in ruby.eclass does not include setting the prefix
+# for the installation step and assumes that arguments can be given
+# also during the install phase.
+each_ruby_install() {
+ local myconf
+
+ if ! use doc ; then
+ myconf="--disable-htmldoc --allow-example-errors"
+ fi
+
+ ${RUBY} setup.rb config --prefix="${D}/usr" \
+ --doc-dir="${D}/usr/share/doc/${P}/html" "$@" \
+ ${myconf} || die "setup.rb config failed"
+ ${RUBY} setup.rb install --prefix="${D}" || die "setup.rb install failed"
+}
+
+all_ruby_install() {
+ dodoc ChangeLog README.html README-Mac-OSX.txt || die
+
+ use examples && dodoc examples/*
+}