summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2007-08-04 06:54:34 +0000
committerHans de Graaff <graaff@gentoo.org>2007-08-04 06:54:34 +0000
commit68370de25921c0a12b1c100f94bb51709dcddee1 (patch)
treed58d98bb3a22c052964a2e05b1406edeb2d5aa07 /dev-ruby
parentBump patchlevel. Convert to font.elass. (diff)
downloadgentoo-2-68370de25921c0a12b1c100f94bb51709dcddee1.tar.gz
gentoo-2-68370de25921c0a12b1c100f94bb51709dcddee1.tar.bz2
gentoo-2-68370de25921c0a12b1c100f94bb51709dcddee1.zip
Version bump with minor bug fixes
(Portage version: 2.1.2.11)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rmagick/ChangeLog7
-rw-r--r--dev-ruby/rmagick/files/digest-rmagick-1.15.83
-rw-r--r--dev-ruby/rmagick/rmagick-1.15.8.ebuild76
3 files changed, 85 insertions, 1 deletions
diff --git a/dev-ruby/rmagick/ChangeLog b/dev-ruby/rmagick/ChangeLog
index 659feedd6bbb..694cf0858c7a 100644
--- a/dev-ruby/rmagick/ChangeLog
+++ b/dev-ruby/rmagick/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rmagick
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.72 2007/07/24 18:38:45 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.73 2007/08/04 06:54:34 graaff Exp $
+
+*rmagick-1.15.8 (04 Aug 2007)
+
+ 04 Aug 2007; Hans de Graaff <graaff@gentoo.org> +rmagick-1.15.8.ebuild:
+ Version bump. Bug fixes to composite function and documentation fixes.
24 Jul 2007; Raúl Porcel <armin76@gentoo.org> rmagick-1.15.7-r1.ebuild:
alpha/ia64 stable
diff --git a/dev-ruby/rmagick/files/digest-rmagick-1.15.8 b/dev-ruby/rmagick/files/digest-rmagick-1.15.8
new file mode 100644
index 000000000000..29c13db0e302
--- /dev/null
+++ b/dev-ruby/rmagick/files/digest-rmagick-1.15.8
@@ -0,0 +1,3 @@
+MD5 8425ca7e4eea54c414bf961d3b7b29b9 RMagick-1.15.8.tar.bz2 958500
+RMD160 7d69c7dc767eba771e0787f1d02c19c5e9823514 RMagick-1.15.8.tar.bz2 958500
+SHA256 638f880800f8bdfb8306e44374e45cd7ca69c2f4fad9cdf572429c7a6c72bbab RMagick-1.15.8.tar.bz2 958500
diff --git a/dev-ruby/rmagick/rmagick-1.15.8.ebuild b/dev-ruby/rmagick/rmagick-1.15.8.ebuild
new file mode 100644
index 000000000000..28d026958f47
--- /dev/null
+++ b/dev-ruby/rmagick/rmagick-1.15.8.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/rmagick-1.15.8.ebuild,v 1.1 2007/08/04 06:54:34 graaff Exp $
+
+inherit ruby
+
+# The gem for this package doesn't seem to play well with portage. It
+# runs a GNUish configure script, with argument passed directly from
+# the gem install command, but gem install doesn't use the same style
+# of arguments. Thus, unless you're smart enough to come up with a
+# fix, please leave this as a source package install.
+
+DESCRIPTION="An interface between Ruby and the ImageMagick(TM) image processing library"
+HOMEPAGE="http://rmagick.rubyforge.org/"
+SRC_URI="http://rubyforge.org/frs/download.php/23511/RMagick-${PV}.tar.bz2"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples doc"
+DEPEND="virtual/ruby
+ >=media-gfx/imagemagick-6.0"
+
+S=${WORKDIR}/RMagick-${PV}
+
+# hdri causes extensive changes in the imagemagick internals, and
+# rmagick is not ready to deal with those, see bug 184356.
+pkg_setup() {
+ if built_with_use --missing false media-gfx/imagemagick hdri ; then
+ eerror "imagemagick is built with the hdri USE flag, this is not supported by rmagick"
+ eerror "please rebuild imagemagick without hdri support if you want to use rmagick"
+ die "imagemagick is built with the hdri USE flag, this is not supported by rmagick"
+ fi
+}
+
+# Using a custom src_compile instead of the ruby one because the ruby
+# one gets confused by an additional setup.rb that should not be used
+# here.
+src_compile() {
+ myconf="${RUBY_ECONF} ${EXTRA_ECONF}"
+
+ # When documentation is built many examples are also run. Not all
+ # of them may work (e.g. due to missing additional dependencies)
+ # so we allow the examples to fail.
+ if ! use doc ; then
+ myconf="${myconf} --disable-htmldoc --enable-allow-example-errors"
+ fi
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --with-ruby=${RUBY} \
+ ${myconf} \
+ "$@" || die "econf failed"
+
+ ruby_emake "$@" || die
+}
+
+# Use a custom src_install instead of the default one in ruby.eclass
+# because the one in ruby.eclass does not include setting the prefix
+# for the installation step.
+src_install() {
+ RUBY_ECONF="${RUBY_ECONF} ${EXTRA_ECONF}"
+
+ ${RUBY} setup.rb config --prefix=${D}/usr "$@" \
+ ${RUBY_ECONF} || die "setup.rb config failed"
+ ${RUBY} setup.rb install --prefix=${D} "$@" \
+ ${RUBY_ECONF} || die "setup.rb install failed"
+
+ cd "${S}"
+ dodoc ChangeLog README.html README-Mac-OSX.txt README.txt
+}