summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2008-10-31 07:39:39 +0000
committerHans de Graaff <graaff@gentoo.org>2008-10-31 07:39:39 +0000
commit6737bc2e8906ac4f4ff9d306a4288791d63a056e (patch)
tree65fc228b8e1c22fadc93e60d4b45525f4a47fc30 /dev-ruby
parentInstall more documentation (diff)
downloadgentoo-2-6737bc2e8906ac4f4ff9d306a4288791d63a056e.tar.gz
gentoo-2-6737bc2e8906ac4f4ff9d306a4288791d63a056e.tar.bz2
gentoo-2-6737bc2e8906ac4f4ff9d306a4288791d63a056e.zip
Remove old versions
(Portage version: 2.1.4.5)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rubygems/ChangeLog7
-rw-r--r--dev-ruby/rubygems/rubygems-0.8.11-r6.ebuild51
-rw-r--r--dev-ruby/rubygems/rubygems-1.0.1.ebuild99
-rw-r--r--dev-ruby/rubygems/rubygems-1.1.0.ebuild100
4 files changed, 6 insertions, 251 deletions
diff --git a/dev-ruby/rubygems/ChangeLog b/dev-ruby/rubygems/ChangeLog
index 8988e2953dc0..bc98245a873c 100644
--- a/dev-ruby/rubygems/ChangeLog
+++ b/dev-ruby/rubygems/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rubygems
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubygems/ChangeLog,v 1.103 2008/10/31 07:38:16 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubygems/ChangeLog,v 1.104 2008/10/31 07:39:39 graaff Exp $
+
+ 31 Oct 2008; Hans de Graaff <graaff@gentoo.org>
+ -rubygems-0.8.11-r6.ebuild, -rubygems-1.0.1.ebuild,
+ -rubygems-1.1.0.ebuild:
+ Remove old versions
31 Oct 2008; Hans de Graaff <graaff@gentoo.org> rubygems-1.2.0.ebuild:
Install ChangeLog and TODO
diff --git a/dev-ruby/rubygems/rubygems-0.8.11-r6.ebuild b/dev-ruby/rubygems/rubygems-0.8.11-r6.ebuild
deleted file mode 100644
index 07c1bee98b97..000000000000
--- a/dev-ruby/rubygems/rubygems-0.8.11-r6.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubygems/rubygems-0.8.11-r6.ebuild,v 1.11 2008/03/26 03:29:59 ricmm Exp $
-
-inherit ruby
-
-DESCRIPTION="Centralized Ruby extension management system"
-HOMEPAGE="http://rubyforge.org/projects/rubygems/"
-LICENSE="Ruby"
-
-# The URL depends implicitly on the version, unfortunately. Even if you
-# change the filename on the end, it still downloads the same file.
-SRC_URI="http://rubyforge.org/frs/download.php/5207/${P}.tgz"
-
-KEYWORDS="amd64 ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
-SLOT="0"
-IUSE=""
-DEPEND=">=dev-lang/ruby-1.8"
-
-PATCHES="${FILESDIR}/no_post_install.patch
- ${FILESDIR}/no-manage_gems.patch
- ${FILESDIR}/${PV}-install.rb.extract_files.patch"
-USE_RUBY="ruby18"
-
-src_compile() {
- return
-}
-
-src_install() {
- # RUBYOPT=-rauto_gem without rubygems installed will cause ruby to fail, bug #158455
- export RUBYOPT="${GENTOO_RUBYOPT}"
- ver=$(${RUBY} -r rbconfig -e 'print Config::CONFIG["MAJOR"] + "." + Config::CONFIG["MINOR"]')
- GEM_HOME=${D}usr/lib/ruby/gems/$ver ruby_src_install
- cp ${FILESDIR}/auto_gem.rb ${D}/$(${RUBY} -r rbconfig -e 'print Config::CONFIG["sitedir"]')
- keepdir /usr/lib/ruby/gems/$ver/doc
- doenvd ${FILESDIR}/10rubygems
-}
-
-pkg_postinst()
-{
- ewarn "If you have previously switched to using ruby18_with_gems using ruby-config, this"
- ewarn "package has removed that file and makes it unnecessary anymore. Please use ruby-config"
- ewarn "to revert back to ruby18."
-}
-
-pkg_postrm()
-{
- # If we potentially downgraded, then getting rid of RUBYOPT from env.d is probably a smart idea.
- env-update
- source /etc/profile
-}
diff --git a/dev-ruby/rubygems/rubygems-1.0.1.ebuild b/dev-ruby/rubygems/rubygems-1.0.1.ebuild
deleted file mode 100644
index 939f7b25c4c7..000000000000
--- a/dev-ruby/rubygems/rubygems-1.0.1.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubygems/rubygems-1.0.1.ebuild,v 1.5 2008/01/21 11:59:25 caster Exp $
-
-inherit ruby
-
-DESCRIPTION="Centralized Ruby extension management system"
-HOMEPAGE="http://rubyforge.org/projects/rubygems/"
-LICENSE="Ruby"
-
-# Needs to be installed first
-RESTRICT="test"
-
-# The URL depends implicitly on the version, unfortunately. Even if you
-# change the filename on the end, it still downloads the same file.
-SRC_URI="http://rubyforge.org/frs/download.php/29548/${P}.tgz"
-
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-SLOT="0"
-IUSE="doc server examples"
-DEPEND=">=dev-lang/ruby-1.8"
-PDEPEND="server? ( dev-ruby/builder )" # index_gem_repository.rb
-
-USE_RUBY="ruby18"
-
-PATCHES="${FILESDIR}/${PN}-0.9.5-setup.patch"
-
-src_unpack() {
- ruby_src_unpack
-
- # Delete mis-packaged . files
- cd "${S}"
- find -name '.*' -type f -print0|xargs -0 rm
-
-}
-
-src_compile() {
- # Allowing ruby_src_compile would be bad with the new setup.rb
- :
-}
-
-src_install() {
- # RUBYOPT=-rauto_gem without rubygems installed will cause ruby to fail, bug #158455
- export RUBYOPT="${GENTOO_RUBYOPT}"
-
- ver=$(${RUBY} -r rbconfig -e 'print Config::CONFIG["ruby_version"]')
-
- # rubygems tries to create GEM_HOME if it doesn't exist, upsetting sandbox,
- # bug #202109
- export GEM_HOME="${D}/usr/$(get_libdir)/ruby/gems/${ver}"
- keepdir /usr/$(get_libdir)/ruby/gems/$ver/{doc,gems,cache,specifications}
-
- myconf="--no-ri"
- if ! use doc; then
- myconf="${myconf} --no-rdoc"
- fi
-
- ${RUBY} setup.rb $myconf --prefix="${D}" || die "setup.rb install failed"
-
- dosym /usr/bin/gem18 /usr/bin/gem
- dosym /usr/bin/update_rubygems18 /usr/bin/update_rubygems
-
- dodoc README
- if use examples; then
- cp -pPR examples "${D}/usr/share/doc/${PF}"
- fi
-
- cp "${FILESDIR}/auto_gem.rb" "${D}"/$(${RUBY} -r rbconfig -e 'print Config::CONFIG["sitedir"]')
- doenvd "${FILESDIR}/10rubygems"
-
- if use server; then
- newinitd "${FILESDIR}/init.d-gem_server" gem_server
- newconfd "${FILESDIR}/conf.d-gem_server" gem_server
- fi
-}
-
-pkg_postinst()
-{
- ver=$(${RUBY} -r rbconfig -e 'print Config::CONFIG["ruby_version"]')
- SOURCE_CACHE="/usr/$(get_libdir)/ruby/gems/$ver/source_cache"
- if [[ -e "${SOURCE_CACHE}" ]]; then
- rm "${SOURCE_CACHE}"
- fi
-
- ewarn "If you have previously switched to using ruby18_with_gems using ruby-config, this"
- ewarn "package has removed that file and makes it unnecessary anymore."
- ewarn "Please use ruby-config to revert back to ruby18."
-}
-
-pkg_postrm()
-{
- ewarn "If you have uninstalled dev-ruby/rubygems. Ruby applications are unlikely"
- ewarn "to run in current shells because of missing auto_gem."
- ewarn "Please run \"unset RUBYOPT\" in your shells before using ruby"
- ewarn "or start new shells"
- ewarn
- ewarn "If you have not uninstalled dev-ruby/rubygems, please do not unset "
- ewarn "RUBYOPT"
-}
diff --git a/dev-ruby/rubygems/rubygems-1.1.0.ebuild b/dev-ruby/rubygems/rubygems-1.1.0.ebuild
deleted file mode 100644
index ef7654280f75..000000000000
--- a/dev-ruby/rubygems/rubygems-1.1.0.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubygems/rubygems-1.1.0.ebuild,v 1.4 2008/04/11 07:00:30 rbrown Exp $
-
-inherit ruby
-
-DESCRIPTION="Centralized Ruby extension management system"
-HOMEPAGE="http://rubyforge.org/projects/rubygems/"
-LICENSE="|| ( Ruby GPL-2 )"
-
-# Needs to be installed first
-RESTRICT="test"
-
-# The URL depends implicitly on the version, unfortunately. Even if you
-# change the filename on the end, it still downloads the same file.
-SRC_URI="http://rubyforge.org/frs/download.php/34638/${P}.tgz"
-
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-SLOT="0"
-IUSE="doc server examples"
-DEPEND=">=dev-lang/ruby-1.8"
-PDEPEND="server? ( dev-ruby/builder )" # index_gem_repository.rb
-
-USE_RUBY="ruby18"
-
-PATCHES="${FILESDIR}/${P}-setup.patch
- ${FILESDIR}/${P}-dependency-installer-install-dir-fix.patch
- "
-
-src_unpack() {
- ruby_src_unpack
-
- # Delete mis-packaged . files
- cd "${S}"
- find -name '.*' -type f -print0|xargs -0 rm
-
-}
-
-src_compile() {
- # Allowing ruby_src_compile would be bad with the new setup.rb
- :
-}
-
-src_install() {
- # RUBYOPT=-rauto_gem without rubygems installed will cause ruby to fail, bug #158455
- export RUBYOPT="${GENTOO_RUBYOPT}"
-
- ver=$(${RUBY} -r rbconfig -e 'print Config::CONFIG["ruby_version"]')
-
- # rubygems tries to create GEM_HOME if it doesn't exist, upsetting sandbox,
- # bug #202109
- export GEM_HOME="${D}/usr/$(get_libdir)/ruby/gems/${ver}"
- keepdir /usr/$(get_libdir)/ruby/gems/$ver/{doc,gems,cache,specifications}
-
- myconf=""
- if ! use doc; then
- myconf="${myconf} --no-ri"
- myconf="${myconf} --no-rdoc"
- fi
-
- ${RUBY} setup.rb $myconf --prefix="${D}" || die "setup.rb install failed"
-
- dosym gem18 /usr/bin/gem || die "dosym gem failed"
-
- dodoc README || die "dodoc README failed"
- if use examples; then
- cp -pPR examples "${D}/usr/share/doc/${PF}" || die "cp examples failed"
- fi
-
- cp "${FILESDIR}/auto_gem.rb" "${D}"/$(${RUBY} -r rbconfig -e 'print Config::CONFIG["sitedir"]') || die "cp auto_gem.rb failed"
- doenvd "${FILESDIR}/10rubygems" || die "doenvd 10rubygems failed"
-
- if use server; then
- newinitd "${FILESDIR}/init.d-gem_server" gem_server || die "newinitd failed"
- newconfd "${FILESDIR}/conf.d-gem_server" gem_server || die "newconfd failed"
- fi
-}
-
-pkg_postinst()
-{
- SOURCE_CACHE="/usr/$(get_libdir)/ruby/gems/$ver/source_cache"
- if [[ -e "${SOURCE_CACHE}" ]]; then
- rm "${SOURCE_CACHE}"
- fi
-
- ewarn "If you have previously switched to using ruby18_with_gems using ruby-config, this"
- ewarn "package has removed that file and makes it unnecessary anymore."
- ewarn "Please use ruby-config to revert back to ruby18."
-}
-
-pkg_postrm()
-{
- ewarn "If you have uninstalled dev-ruby/rubygems. Ruby applications are unlikely"
- ewarn "to run in current shells because of missing auto_gem."
- ewarn "Please run \"unset RUBYOPT\" in your shells before using ruby"
- ewarn "or start new shells"
- ewarn
- ewarn "If you have not uninstalled dev-ruby/rubygems, please do not unset "
- ewarn "RUBYOPT"
-}