summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-02-19 07:18:33 +0000
committerHans de Graaff <graaff@gentoo.org>2014-02-19 07:18:33 +0000
commit6123822ee463e83f058f723c918c19370b31a6f1 (patch)
tree1ae8bc0c9d44ba0925008a1462a536145a088456 /dev-ruby
parentVersion bump for security bug 501750. (diff)
downloadgentoo-2-6123822ee463e83f058f723c918c19370b31a6f1.tar.gz
gentoo-2-6123822ee463e83f058f723c918c19370b31a6f1.tar.bz2
gentoo-2-6123822ee463e83f058f723c918c19370b31a6f1.zip
Version bump for security bug 501750.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activemodel/ChangeLog9
-rw-r--r--dev-ruby/activemodel/activemodel-3.2.17.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/dev-ruby/activemodel/ChangeLog b/dev-ruby/activemodel/ChangeLog
index a19cc53e9fba..40ebe753bcaa 100644
--- a/dev-ruby/activemodel/ChangeLog
+++ b/dev-ruby/activemodel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activemodel
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.67 2013/12/16 20:11:15 graaff Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.68 2014/02/19 07:18:33 graaff Exp $
+
+*activemodel-3.2.17 (19 Feb 2014)
+
+ 19 Feb 2014; Hans de Graaff <graaff@gentoo.org> +activemodel-3.2.17.ebuild:
+ Version bump for security bug 501750.
16 Dec 2013; Hans de Graaff <graaff@gentoo.org> -activemodel-3.2.15.ebuild,
-activemodel-4.0.0.ebuild:
diff --git a/dev-ruby/activemodel/activemodel-3.2.17.ebuild b/dev-ruby/activemodel/activemodel-3.2.17.ebuild
new file mode 100644
index 000000000000..30a573f5ff06
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-3.2.17.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-3.2.17.ebuild,v 1.1 2014/02/19 07:18:33 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.0.0:3
+ >=dev-ruby/bcrypt-ruby-3.0.0"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/test-unit:2
+ >=dev-ruby/mocha-0.13.0:0.13
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+
+ # Make sure we use the test-unit gem since ruby18 does not provide
+ # all the test-unit features needed.
+ sed -i -e '1igem "test-unit"' test/cases/helper.rb || die
+
+ # Fix bcrypt dependency since bcrypt uses semantic versioning.
+ sed -i -e '/bcrypt-ruby/ s/3.0.0/3.0/' lib/active_model/secure_password.rb || die
+}