summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-06-09 17:08:48 +0000
committerHans de Graaff <graaff@gentoo.org>2011-06-09 17:08:48 +0000
commit592e41a344634c84b718d63bc8940fe0c1243481 (patch)
tree553ecad83aaa6d93987ed1524f731ec6dec5dffb /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-592e41a344634c84b718d63bc8940fe0c1243481.tar.gz
gentoo-2-592e41a344634c84b718d63bc8940fe0c1243481.tar.bz2
gentoo-2-592e41a344634c84b718d63bc8940fe0c1243481.zip
Version bump.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actionmailer/ChangeLog7
-rw-r--r--dev-ruby/actionmailer/actionmailer-2.3.12.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index eb0d57b6cc45..a361c43af931 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.157 2011/06/09 15:20:30 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.158 2011/06/09 17:08:48 graaff Exp $
+
+*actionmailer-2.3.12 (09 Jun 2011)
+
+ 09 Jun 2011; Hans de Graaff <graaff@gentoo.org> +actionmailer-2.3.12.ebuild:
+ Version bump.
09 Jun 2011; Hans de Graaff <graaff@gentoo.org> -actionmailer-2.2.3.ebuild:
Remove old version.
diff --git a/dev-ruby/actionmailer/actionmailer-2.3.12.ebuild b/dev-ruby/actionmailer/actionmailer-2.3.12.ebuild
new file mode 100644
index 000000000000..6d807563d229
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-2.3.12.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-2.3.12.ebuild,v 1.1 2011/06/09 17:08:48 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_PATCHES=( "${PN}-2.3.10-rails3.patch" )
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/text-format-0.6.3
+ >=dev-ruby/tmail-1.2.3"
+ruby_add_bdepend "test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+)"
+
+all_ruby_prepare() {
+ # Custom template not found in package
+ sed -i -e '/horo/d' Rakefile || die
+}