summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-03-31 07:43:13 +0000
committerHans de Graaff <graaff@gentoo.org>2013-03-31 07:43:13 +0000
commit58b23807b277a6baca4e61931ac66e9cf63fd045 (patch)
tree05f07610ef640771d20606257b1b8232d218edae /dev-ruby
parentVersion bump for security bug 462452. (diff)
downloadgentoo-2-58b23807b277a6baca4e61931ac66e9cf63fd045.tar.gz
gentoo-2-58b23807b277a6baca4e61931ac66e9cf63fd045.tar.bz2
gentoo-2-58b23807b277a6baca4e61931ac66e9cf63fd045.zip
Version bump for security bug 462452.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activemodel/ChangeLog7
-rw-r--r--dev-ruby/activemodel/activemodel-3.2.13.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ruby/activemodel/ChangeLog b/dev-ruby/activemodel/ChangeLog
index 27c06d429628..5e1c50c63618 100644
--- a/dev-ruby/activemodel/ChangeLog
+++ b/dev-ruby/activemodel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activemodel
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.56 2013/03/30 13:16:29 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.57 2013/03/31 07:43:13 graaff Exp $
+
+*activemodel-3.2.13 (31 Mar 2013)
+
+ 31 Mar 2013; Hans de Graaff <graaff@gentoo.org> +activemodel-3.2.13.ebuild:
+ Version bump for security bug 462452.
*activemodel-3.1.12 (30 Mar 2013)
diff --git a/dev-ruby/activemodel/activemodel-3.2.13.ebuild b/dev-ruby/activemodel/activemodel-3.2.13.ebuild
new file mode 100644
index 000000000000..3a341ad9ae91
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-3.2.13.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-3.2.13.ebuild,v 1.1 2013/03/31 07:43:13 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.0.0:3
+ >=dev-ruby/bcrypt-ruby-3.0.0"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}