summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2007-09-01 21:58:33 +0000
committerJoshua Nichols <nichoj@gentoo.org>2007-09-01 21:58:33 +0000
commit4b173a3ff0164568a2fd4a445c16eaa54a0f0c3f (patch)
treefba733f8c05bbb5f8aa357025e039a2890a62889 /dev-ruby
parentAdded ~amd64 keyword as per bug 102677. (diff)
downloadgentoo-2-4b173a3ff0164568a2fd4a445c16eaa54a0f0c3f.tar.gz
gentoo-2-4b173a3ff0164568a2fd4a445c16eaa54a0f0c3f.tar.bz2
gentoo-2-4b173a3ff0164568a2fd4a445c16eaa54a0f0c3f.zip
Version bump for 2.0.0, and revision bump for 1.4.1-r1. They now post-depend on capistrano-launcher which provides /usr/bin/cap. Removed unneeded \'inherit ruby\', and USE_RUBY. Dropped ia64 keyword for > 1.9, as highline is lacking a keyword.
(Portage version: 2.1.3.7)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/capistrano/ChangeLog18
-rw-r--r--dev-ruby/capistrano/capistrano-1.4.1-r1.ebuild28
-rw-r--r--dev-ruby/capistrano/capistrano-1.4.1.ebuild6
-rw-r--r--dev-ruby/capistrano/capistrano-1.99.1.ebuild8
-rw-r--r--dev-ruby/capistrano/capistrano-1.99.3.ebuild8
-rw-r--r--dev-ruby/capistrano/capistrano-2.0.0.ebuild29
-rw-r--r--dev-ruby/capistrano/files/digest-capistrano-1.4.1-r13
-rw-r--r--dev-ruby/capistrano/files/digest-capistrano-2.0.03
8 files changed, 85 insertions, 18 deletions
diff --git a/dev-ruby/capistrano/ChangeLog b/dev-ruby/capistrano/ChangeLog
index b9f135fdb205..3a57afba8bcc 100644
--- a/dev-ruby/capistrano/ChangeLog
+++ b/dev-ruby/capistrano/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-ruby/capistrano
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/ChangeLog,v 1.19 2007/09/01 19:55:26 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/ChangeLog,v 1.20 2007/09/01 21:58:33 nichoj Exp $
+
+*capistrano-2.0.0 (01 Sep 2007)
+*capistrano-1.4.1-r1 (01 Sep 2007)
+
+ 01 Sep 2007; Joshua Nichols <nichoj@gentoo.org> capistrano-1.4.1.ebuild,
+ +capistrano-1.4.1-r1.ebuild, capistrano-1.99.1.ebuild,
+ capistrano-1.99.3.ebuild, +capistrano-2.0.0.ebuild:
+ Version bump for 2.0.0, and revision bump for 1.4.1-r1. They now post-depend
+ on capistrano-launcher which provides /usr/bin/cap. Removed unneeded
+ 'inherit ruby', and USE_RUBY. Dropped ia64 keyword for > 1.9, as highline is lacking a keyword.
01 Sep 2007; Joshua Nichols <nichoj@gentoo.org> capistrano-1.4.1.ebuild,
capistrano-1.99.1.ebuild, capistrano-1.99.3.ebuild:
@@ -33,7 +43,7 @@
capistrano-1.4.1.ebuild:
stable x86, bug 173040
- 02 Apr 2007; Raúl Porcel <armin76@gentoo.org> capistrano-1.4.1.ebuild:
+ 02 Apr 2007; Raúl Porcel <armin76@gentoo.org> capistrano-1.4.1.ebuild:
ia64 stable wrt bug 173040
04 Mar 2007; Tom Gall <tgall@gentoo.org> capistrano-1.4.1.ebuild:
@@ -56,11 +66,11 @@
+capistrano-1.3.1.ebuild:
Version bump.
- 05 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
+ 05 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
capistrano-1.1.0.ebuild:
Convert to use elog.
- 11 Nov 2006; Piotr Jaroszyński <peper@gentoo.org>
+ 11 Nov 2006; Piotr Jaroszyński <peper@gentoo.org>
capistrano-1.1.0.ebuild:
Add ~amd64 wrt bug #154697.
diff --git a/dev-ruby/capistrano/capistrano-1.4.1-r1.ebuild b/dev-ruby/capistrano/capistrano-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..848b2e445d36
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-1.4.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/capistrano-1.4.1-r1.ebuild,v 1.1 2007/09/01 21:58:33 nichoj Exp $
+
+inherit gems
+
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="http://rubyforge.org/projects/capistrano/"
+SRC_URI="http://gems.rubyforge.org/gems/${P}.gem"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~ia64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ruby-1.8.2
+ >=dev-ruby/rake-0.7.0
+ >=dev-ruby/net-ssh-1.0.10
+ >=dev-ruby/net-sftp-1.1.0"
+PDEPEND="dev-ruby/capistrano-launcher"
+
+src_install() {
+ gems_src_install
+
+ # Deleted cap, as it will be provided by capistrano-launcher
+ rm "${D}/usr/bin/cap"
+ rm "${D}/${GEMSDIR}/bin/cap"
+}
diff --git a/dev-ruby/capistrano/capistrano-1.4.1.ebuild b/dev-ruby/capistrano/capistrano-1.4.1.ebuild
index 0d791b6e51f1..d2cbe963983c 100644
--- a/dev-ruby/capistrano/capistrano-1.4.1.ebuild
+++ b/dev-ruby/capistrano/capistrano-1.4.1.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/capistrano-1.4.1.ebuild,v 1.7 2007/09/01 19:55:26 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/capistrano-1.4.1.ebuild,v 1.8 2007/09/01 21:58:33 nichoj Exp $
-inherit ruby gems
+inherit gems
-USE_RUBY="ruby18"
DESCRIPTION="A distributed application deployment system"
HOMEPAGE="http://rubyforge.org/projects/capistrano/"
SRC_URI="http://gems.rubyforge.org/gems/${P}.gem"
@@ -13,7 +12,6 @@ LICENSE="MIT"
SLOT="1"
KEYWORDS="amd64 ia64 ppc64 x86"
IUSE=""
-#RESTRICT="test"
DEPEND=">=dev-lang/ruby-1.8.2
>=dev-ruby/rake-0.7.0
diff --git a/dev-ruby/capistrano/capistrano-1.99.1.ebuild b/dev-ruby/capistrano/capistrano-1.99.1.ebuild
index c0a5902c637d..64818ad45230 100644
--- a/dev-ruby/capistrano/capistrano-1.99.1.ebuild
+++ b/dev-ruby/capistrano/capistrano-1.99.1.ebuild
@@ -1,19 +1,17 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/capistrano-1.99.1.ebuild,v 1.2 2007/09/01 19:55:26 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/capistrano-1.99.1.ebuild,v 1.3 2007/09/01 21:58:33 nichoj Exp $
-inherit ruby gems
+inherit gems
-USE_RUBY="ruby18"
DESCRIPTION="A distributed application deployment system"
HOMEPAGE="http://capify.org/"
SRC_URI="http://gems.rubyonrails.com/gems/${P}.gem"
LICENSE="MIT"
SLOT="2"
-KEYWORDS="~amd64 ~ia64 ~ppc64 ~x86"
+KEYWORDS="~amd64 ~ppc64 ~x86"
IUSE=""
-#RESTRICT="test"
DEPEND=">=dev-lang/ruby-1.8.2
>=dev-ruby/rake-0.7.0
diff --git a/dev-ruby/capistrano/capistrano-1.99.3.ebuild b/dev-ruby/capistrano/capistrano-1.99.3.ebuild
index 79d4b3c6b572..ea748f7e5cc7 100644
--- a/dev-ruby/capistrano/capistrano-1.99.3.ebuild
+++ b/dev-ruby/capistrano/capistrano-1.99.3.ebuild
@@ -1,19 +1,17 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/capistrano-1.99.3.ebuild,v 1.2 2007/09/01 19:55:26 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/capistrano-1.99.3.ebuild,v 1.3 2007/09/01 21:58:33 nichoj Exp $
-inherit ruby gems
+inherit gems
-USE_RUBY="ruby18"
DESCRIPTION="A distributed application deployment system"
HOMEPAGE="http://capify.org/"
SRC_URI="http://gems.rubyonrails.com/gems/${P}.gem"
LICENSE="MIT"
SLOT="2"
-KEYWORDS="~amd64 ~ia64 ~ppc64 ~x86"
+KEYWORDS="~amd64 ~ppc64 ~x86"
IUSE=""
-#RESTRICT="test"
DEPEND=">=dev-lang/ruby-1.8.2
>=dev-ruby/rake-0.7.0
diff --git a/dev-ruby/capistrano/capistrano-2.0.0.ebuild b/dev-ruby/capistrano/capistrano-2.0.0.ebuild
new file mode 100644
index 000000000000..82a456b59082
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-2.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/capistrano-2.0.0.ebuild,v 1.1 2007/09/01 21:58:33 nichoj Exp $
+
+inherit gems
+
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="http://capify.org/"
+SRC_URI="http://gems.rubyforge.org/gems/${P}.gem"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ruby-1.8.2
+ >=dev-ruby/rake-0.7.0
+ >=dev-ruby/net-ssh-1.0.10
+ >=dev-ruby/net-sftp-1.1.0
+ >=dev-ruby/highline-1.2.7"
+PDEPEND="dev-ruby/capistrano-launcher"
+
+src_install() {
+ gems_src_install
+
+ # Deleted cap, as it will be provided by capistrano-launcher
+ rm "${D}/usr/bin/cap"
+ rm "${D}/${GEMSDIR}/bin/cap"
+}
diff --git a/dev-ruby/capistrano/files/digest-capistrano-1.4.1-r1 b/dev-ruby/capistrano/files/digest-capistrano-1.4.1-r1
new file mode 100644
index 000000000000..20d533180bd3
--- /dev/null
+++ b/dev-ruby/capistrano/files/digest-capistrano-1.4.1-r1
@@ -0,0 +1,3 @@
+MD5 c35b2863b5c9110dc0dff51e85ffac98 capistrano-1.4.1.gem 49152
+RMD160 f6ba17b610c039ed88db6bb5ae86bd21a61ad5bf capistrano-1.4.1.gem 49152
+SHA256 2ed5ec04a2492fa5a9f9dc9b613990c5866935a8c193a9476fd73b29c98a7313 capistrano-1.4.1.gem 49152
diff --git a/dev-ruby/capistrano/files/digest-capistrano-2.0.0 b/dev-ruby/capistrano/files/digest-capistrano-2.0.0
new file mode 100644
index 000000000000..749e9ec539fd
--- /dev/null
+++ b/dev-ruby/capistrano/files/digest-capistrano-2.0.0
@@ -0,0 +1,3 @@
+MD5 1e7cbfc6517cff98022409dd21aea6f1 capistrano-2.0.0.gem 84480
+RMD160 15c01d1a2313f7e0e7ac61dd5d415ad939ab5c1a capistrano-2.0.0.gem 84480
+SHA256 353dfe6868d6c2007d63b9f62e833581f0a839850d3646d90ca258e964cf2ad6 capistrano-2.0.0.gem 84480