summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-06-05 11:16:39 +0000
committerHans de Graaff <graaff@gentoo.org>2010-06-05 11:16:39 +0000
commit4a926db333a9df9f1fe74f3f4c65b5875fad3473 (patch)
tree122537dfb06b4fae059df7c24228b8b6600008fd /dev-ruby
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-4a926db333a9df9f1fe74f3f4c65b5875fad3473.tar.gz
gentoo-2-4a926db333a9df9f1fe74f3f4c65b5875fad3473.tar.bz2
gentoo-2-4a926db333a9df9f1fe74f3f4c65b5875fad3473.zip
Version bump. Our rubyforge patch is no longer needed.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/hoe/ChangeLog7
-rw-r--r--dev-ruby/hoe/hoe-2.6.1.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-ruby/hoe/ChangeLog b/dev-ruby/hoe/ChangeLog
index 7f254e106147..5c250bf31a95 100644
--- a/dev-ruby/hoe/ChangeLog
+++ b/dev-ruby/hoe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/hoe
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/ChangeLog,v 1.79 2010/05/22 22:58:55 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/ChangeLog,v 1.80 2010/06/05 11:16:39 graaff Exp $
+
+*hoe-2.6.1 (05 Jun 2010)
+
+ 05 Jun 2010; Hans de Graaff <graaff@gentoo.org> +hoe-2.6.1.ebuild:
+ Version bump. Our rubyforge patch is no longer needed.
22 May 2010; Alex Legler <a3li@gentoo.org> hoe-2.6.0-r1.ebuild:
Add REE18 support
diff --git a/dev-ruby/hoe/hoe-2.6.1.ebuild b/dev-ruby/hoe/hoe-2.6.1.ebuild
new file mode 100644
index 000000000000..e0c5e6cb385a
--- /dev/null
+++ b/dev-ruby/hoe/hoe-2.6.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/hoe-2.6.1.ebuild,v 1.1 2010/06/05 11:16:39 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt"
+
+RUBY_FAKEGEM_EXTRAINSTALL="template"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hoe extends rake to provide full project automation."
+HOMEPAGE="http://seattlerb.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+# - also requires dev-ruby/hoe-seattlerb for 1.9;
+# - dev-ruby/gemcutter is an optional dependency at both runtime and
+# test-time, at least for us;
+# - rubyforge is loaded at runtime when needed, so we don't strictly
+# depend on it at runtime, but we need it for tests (for now);
+ruby_add_bdepend "test? ( virtual/ruby-minitest >=dev-ruby/rubyforge-2.0.3 )"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.7"