summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-10-05 10:03:43 +0000
committerHans de Graaff <graaff@gentoo.org>2012-10-05 10:03:43 +0000
commit399ae3740da75253a8bc4a265a41680a77c3e55e (patch)
tree1fd3bbbaf96a6fe328d5262c0ea2ad59e23dcde0 /dev-ruby
parentFlip dependencies around in || ( ) atom wrt #436672 (diff)
downloadgentoo-2-399ae3740da75253a8bc4a265a41680a77c3e55e.tar.gz
gentoo-2-399ae3740da75253a8bc4a265a41680a77c3e55e.tar.bz2
gentoo-2-399ae3740da75253a8bc4a265a41680a77c3e55e.zip
Version bump.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/fast_gettext/ChangeLog7
-rw-r--r--dev-ruby/fast_gettext/fast_gettext-0.6.10.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ruby/fast_gettext/ChangeLog b/dev-ruby/fast_gettext/ChangeLog
index 229c008f49be..ef47a66d09b3 100644
--- a/dev-ruby/fast_gettext/ChangeLog
+++ b/dev-ruby/fast_gettext/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/fast_gettext
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/ChangeLog,v 1.17 2012/08/06 17:29:08 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/ChangeLog,v 1.18 2012/10/05 10:03:43 graaff Exp $
+
+*fast_gettext-0.6.10 (05 Oct 2012)
+
+ 05 Oct 2012; Hans de Graaff <graaff@gentoo.org> +fast_gettext-0.6.10.ebuild:
+ Version bump.
*fast_gettext-0.6.9 (06 Aug 2012)
diff --git a/dev-ruby/fast_gettext/fast_gettext-0.6.10.ebuild b/dev-ruby/fast_gettext/fast_gettext-0.6.10.ebuild
new file mode 100644
index 000000000000..7700fe59d7a3
--- /dev/null
+++ b/dev-ruby/fast_gettext/fast_gettext-0.6.10.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/fast_gettext-0.6.10.ebuild,v 1.1 2012/10/05 10:03:43 graaff Exp $
+
+EAPI="4"
+
+# jruby support requires sqlite3 support for jruby.
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG Readme.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="GetText but 3.5 x faster, 560 x less memory, simple, clean namespace (7 vs 34) and threadsave!"
+HOMEPAGE="https://github.com/grosser/fast_gettext"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/activerecord dev-ruby/bundler )"
+
+all_ruby_prepare() {
+ rm Gemfile.lock || die
+
+ # Remove jeweler from Gemfile since it is not needed for tests.
+ sed -i '/jeweler/d' Gemfile || die
+
+ # Avoid unneeded dependency on git.
+ sed -i -e '/git ls-files/ s:^:#:' fast_gettext.gemspec || die
+
+ # Don't run a test that requires safe mode which we can't provide
+ # due to insecure directory settings for the portage dir. This spec
+ # also calls out to ruby which won't work with different ruby
+ # implementations.
+ sed -i -e '/can work in SAFE mode/,/end/ s:^:#:' spec/fast_gettext/translation_repository/mo_spec.rb || die
+}
+
+each_ruby_prepare() {
+ # Make sure the right ruby interpreter is used
+ sed -i -e "s:bundle exec ruby:bundle exec ${RUBY}:" spec/fast_gettext/vendor/*spec.rb || die
+}