summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-02-08 06:37:15 +0000
committerHans de Graaff <graaff@gentoo.org>2015-02-08 06:37:15 +0000
commit3586cc5bf21fa79031621b425e9fe0a71687bf2e (patch)
tree52c0d884efc38622bd23d5862569deb95aa5231e /dev-ruby
parentStable for HPPA (bug #530904). (diff)
downloadgentoo-2-3586cc5bf21fa79031621b425e9fe0a71687bf2e.tar.gz
gentoo-2-3586cc5bf21fa79031621b425e9fe0a71687bf2e.tar.bz2
gentoo-2-3586cc5bf21fa79031621b425e9fe0a71687bf2e.zip
Version bump.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/addressable/ChangeLog9
-rw-r--r--dev-ruby/addressable/addressable-2.3.7.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/dev-ruby/addressable/ChangeLog b/dev-ruby/addressable/ChangeLog
index 7fafc4522c37..a703d127518b 100644
--- a/dev-ruby/addressable/ChangeLog
+++ b/dev-ruby/addressable/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/addressable
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/addressable/ChangeLog,v 1.45 2014/10/30 14:03:51 mrueg Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/addressable/ChangeLog,v 1.46 2015/02/08 06:37:15 graaff Exp $
+
+*addressable-2.3.7 (08 Feb 2015)
+
+ 08 Feb 2015; Hans de Graaff <graaff@gentoo.org> +addressable-2.3.7.ebuild:
+ Version bump.
30 Oct 2014; Manuel Rüger <mrueg@gentoo.org> addressable-2.3.5.ebuild,
addressable-2.3.6.ebuild:
diff --git a/dev-ruby/addressable/addressable-2.3.7.ebuild b/dev-ruby/addressable/addressable-2.3.7.ebuild
new file mode 100644
index 000000000000..3ee1f407ca02
--- /dev/null
+++ b/dev-ruby/addressable/addressable-2.3.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/addressable/addressable-2.3.7.ebuild,v 1.1 2015/02/08 06:37:15 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC="doc:yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RAKE_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A replacement for the URI implementation that is part of Ruby's standard library"
+HOMEPAGE="https://rubygems.org/gems/addressable https://github.com/sporkmonger/addressable"
+
+LICENSE="Apache-2.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+all_ruby_prepare() {
+ # Remove spec-related tasks so that we don't need to require rspec
+ # just to build the documentation, bug 383611.
+ sed -i -e '/spectask/d' Rakefile || die
+ rm tasks/rspec.rake || die
+ sed -i -e '/[Cc]overalls/d' spec/spec_helper.rb || die
+
+ # Remove specs requiring network connectivity
+ rm spec/addressable/net_http_compat_spec.rb || die
+}