summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-01-15 13:30:02 +0000
committerHans de Graaff <graaff@gentoo.org>2012-01-15 13:30:02 +0000
commit34cdd78767731880e227536c39f1899d2d528809 (patch)
treedeadab51ae9dc90189f4ef87c530e7497a8a50f6 /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-34cdd78767731880e227536c39f1899d2d528809.tar.gz
gentoo-2-34cdd78767731880e227536c39f1899d2d528809.tar.bz2
gentoo-2-34cdd78767731880e227536c39f1899d2d528809.zip
Version bump. Drop keywords due to new metaclass dependency, bug 398985.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/mocha/ChangeLog9
-rw-r--r--dev-ruby/mocha/mocha-0.10.0.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-ruby/mocha/ChangeLog b/dev-ruby/mocha/ChangeLog
index a5447da2ada2..3b5aa26c885a 100644
--- a/dev-ruby/mocha/ChangeLog
+++ b/dev-ruby/mocha/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/mocha
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mocha/ChangeLog,v 1.39 2011/12/31 20:36:03 grobian Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mocha/ChangeLog,v 1.40 2012/01/15 13:30:02 graaff Exp $
+
+*mocha-0.10.0 (15 Jan 2012)
+
+ 15 Jan 2012; Hans de Graaff <graaff@gentoo.org> +mocha-0.10.0.ebuild:
+ Version bump. Drop keywords due to new metaclass dependency, bug 398985.
31 Dec 2011; Fabian Groffen <grobian@gentoo.org> mocha-0.9.12.ebuild:
Add Prefix keywords, bug #396547
diff --git a/dev-ruby/mocha/mocha-0.10.0.ebuild b/dev-ruby/mocha/mocha-0.10.0.ebuild
new file mode 100644
index 000000000000..ed5198d6915a
--- /dev/null
+++ b/dev-ruby/mocha/mocha-0.10.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mocha/mocha-0.10.0.ebuild,v 1.1 2012/01/15 13:30:02 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="test:units"
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc RELEASE.rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby library for mocking and stubbing using a syntax like that of JMock, and SchMock"
+HOMEPAGE="http://mocha.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/coderay )"
+
+ruby_add_rdepend "dev-ruby/metaclass" #metaclass ~> 0.0.1
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' -e '1iload "lib/mocha/version.rb"' Rakefile || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc; then
+ rake examples || die
+ fi
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*.rb || die
+}