summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-12-14 16:31:11 +0000
committerHans de Graaff <graaff@gentoo.org>2012-12-14 16:31:11 +0000
commit3147ab60347225a5297a7fd81f558f0867500c1a (patch)
treeaf9080b36d09ab45aa8ac9ea9fc398bb5c89292f /dev-ruby
parentRemove redundant USE=upnp description; it matches the global flag meaning. (diff)
downloadgentoo-2-3147ab60347225a5297a7fd81f558f0867500c1a.tar.gz
gentoo-2-3147ab60347225a5297a7fd81f558f0867500c1a.tar.bz2
gentoo-2-3147ab60347225a5297a7fd81f558f0867500c1a.zip
Version bump. Run tests through bundler to make sure all the bits and pieces are loaded.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/best_in_place/ChangeLog8
-rw-r--r--dev-ruby/best_in_place/best_in_place-1.1.3.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-ruby/best_in_place/ChangeLog b/dev-ruby/best_in_place/ChangeLog
index 2999a1d5f094..a1c1c980e898 100644
--- a/dev-ruby/best_in_place/ChangeLog
+++ b/dev-ruby/best_in_place/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/best_in_place
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/best_in_place/ChangeLog,v 1.9 2012/08/16 03:51:44 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/best_in_place/ChangeLog,v 1.10 2012/12/14 16:31:11 graaff Exp $
+
+*best_in_place-1.1.3 (14 Dec 2012)
+
+ 14 Dec 2012; Hans de Graaff <graaff@gentoo.org> +best_in_place-1.1.3.ebuild:
+ Version bump. Run tests through bundler to make sure all the bits and pieces
+ are loaded.
16 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org>
best_in_place-1.1.2.ebuild:
diff --git a/dev-ruby/best_in_place/best_in_place-1.1.3.ebuild b/dev-ruby/best_in_place/best_in_place-1.1.3.ebuild
new file mode 100644
index 000000000000..5268ef810939
--- /dev/null
+++ b/dev-ruby/best_in_place/best_in_place-1.1.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/best_in_place/best_in_place-1.1.3.ebuild,v 1.1 2012/12/14 16:31:11 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+# if ever needed
+#GITHUB_USER="bernat"
+#GITHUB_PROJECT="${PN}"
+#RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
+
+inherit virtualx ruby-fakegem
+
+DESCRIPTION="In-place editor helper for Rails 3o"
+HOMEPAGE="http://github.com/bernat/best_in_place"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rails-3.1
+ dev-ruby/jquery-rails"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/rspec-rails
+ >=dev-ruby/nokogiri-1.5.0
+ >=dev-ruby/capybara-1.0.1
+ dev-ruby/rails:3.2
+ >=dev-ruby/sqlite3-1.3.4-r1
+ dev-ruby/kramdown
+ )"
+
+DEPEND+=" test? ( www-client/firefox dev-ruby/bundler )"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1.0-kramdown.patch
+
+ sed -i \
+ -e '/git ls-files/d' \
+ -e '/rspec-rails/s:,.*::' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -i \
+ -e '/gem .rails/s:3.2: ~> 3.2.0:' \
+ -e '/group :assets/,/^end/ d' \
+ test_app/Gemfile || die
+}
+
+each_ruby_test() {
+ RAILS_ENV=test ${RUBY} -C test_app -S rake db:migrate || die "test_app migration failed"
+ VIRTUALX_COMMAND="${RUBY}" virtualmake -S bundle exec rspec spec || die "Specs failed"
+}