summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-06-09 05:48:01 +0000
committerHans de Graaff <graaff@gentoo.org>2015-06-09 05:48:01 +0000
commit2b4be454fb7077c2ff896e3c7b97b450d077eb75 (patch)
treefeded5c7541880577ae501cba8b2fee583d49fd1 /dev-ruby
parentbump to 1.6.6 (diff)
downloadgentoo-2-2b4be454fb7077c2ff896e3c7b97b450d077eb75.tar.gz
gentoo-2-2b4be454fb7077c2ff896e3c7b97b450d077eb75.tar.bz2
gentoo-2-2b4be454fb7077c2ff896e3c7b97b450d077eb75.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/temple/ChangeLog7
-rw-r--r--dev-ruby/temple/temple-0.6.10.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-ruby/temple/ChangeLog b/dev-ruby/temple/ChangeLog
index 4b824fc37c30..595c0f91d0b6 100644
--- a/dev-ruby/temple/ChangeLog
+++ b/dev-ruby/temple/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/temple
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/temple/ChangeLog,v 1.28 2015/06/09 05:25:19 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/temple/ChangeLog,v 1.29 2015/06/09 05:48:01 graaff Exp $
+
+*temple-0.6.10 (09 Jun 2015)
+
+ 09 Jun 2015; Hans de Graaff <graaff@gentoo.org> +temple-0.6.10.ebuild:
+ Version bump.
09 Jun 2015; Hans de Graaff <graaff@gentoo.org> temple-0.7.5.ebuild:
Update SLOT.
diff --git a/dev-ruby/temple/temple-0.6.10.ebuild b/dev-ruby/temple/temple-0.6.10.ebuild
new file mode 100644
index 000000000000..5570997e5683
--- /dev/null
+++ b/dev-ruby/temple/temple-0.6.10.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/temple/temple-0.6.10.ebuild,v 1.1 2015/06/09 05:48:01 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES EXPRESSIONS.md README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="An abstraction and a framework for compiling templates to pure Ruby"
+HOMEPAGE="https://github.com/judofyr/temple"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/bacon dev-ruby/tilt )"
+
+all_ruby_prepare() {
+ # Avoid test failing based on specific load ordering
+ sed -i -e '/should have use_html_safe option/,/^ end/ s:^:#:' \
+ test/filters/test_escapable.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test -S bacon --automatic --quiet || die
+}