summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-11-15 07:17:51 +0000
committerHans de Graaff <graaff@gentoo.org>2012-11-15 07:17:51 +0000
commit2b195a9b3017243e983a685e8a9e766a876ac7a8 (patch)
treed919c1e1c59949ac788fc97342e3b0c1f316dcc4 /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-2b195a9b3017243e983a685e8a9e766a876ac7a8.tar.gz
gentoo-2-2b195a9b3017243e983a685e8a9e766a876ac7a8.tar.bz2
gentoo-2-2b195a9b3017243e983a685e8a9e766a876ac7a8.zip
Version bump.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rspec-expectations/ChangeLog8
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-2.12.0.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-ruby/rspec-expectations/ChangeLog b/dev-ruby/rspec-expectations/ChangeLog
index 69c6dee68f4f..ea3a0ed60d6b 100644
--- a/dev-ruby/rspec-expectations/ChangeLog
+++ b/dev-ruby/rspec-expectations/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rspec-expectations
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.36 2012/11/13 19:20:11 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.37 2012/11/15 07:17:51 graaff Exp $
+
+*rspec-expectations-2.12.0 (15 Nov 2012)
+
+ 15 Nov 2012; Hans de Graaff <graaff@gentoo.org>
+ +rspec-expectations-2.12.0.ebuild:
+ Version bump.
13 Nov 2012; Hans de Graaff <graaff@gentoo.org>
-rspec-expectations-2.6.0.ebuild:
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-2.12.0.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-2.12.0.ebuild
new file mode 100644
index 000000000000..9fd549b383d4
--- /dev/null
+++ b/dev-ruby/rspec-expectations/rspec-expectations-2.12.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/rspec-expectations-2.12.0.ebuild,v 1.1 2012/11/15 07:17:51 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_S="rspec-${PN}-*"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+SRC_URI="https://github.com/rspec/${PN}/tarball/v${PV} -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.1.3"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rspec-core-2.11.0:2
+ dev-ruby/rspec-mocks:2
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm Gemfile || die
+
+ # fix up the gemspecs
+ sed -i \
+ -e '/git ls/d' \
+ -e '/add_development_dependency/d' \
+ "${RUBY_FAKEGEM_GEMSPEC}" || die
+}