summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2007-03-04 07:59:21 +0000
committerHans de Graaff <graaff@gentoo.org>2007-03-04 07:59:21 +0000
commit2af03d4525d486db740e818ceec156325f898d21 (patch)
treeaf29b23f7a97507b183d43e2e264d473f3e99f3a /dev-ruby
parentReplacing einfo with elog (diff)
downloadgentoo-2-2af03d4525d486db740e818ceec156325f898d21.tar.gz
gentoo-2-2af03d4525d486db740e818ceec156325f898d21.tar.bz2
gentoo-2-2af03d4525d486db740e818ceec156325f898d21.zip
Version bump.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rmagick/ChangeLog9
-rw-r--r--dev-ruby/rmagick/files/digest-rmagick-1.15.43
-rw-r--r--dev-ruby/rmagick/rmagick-1.15.4.ebuild66
3 files changed, 77 insertions, 1 deletions
diff --git a/dev-ruby/rmagick/ChangeLog b/dev-ruby/rmagick/ChangeLog
index c29ee3203adc..81e8533434a2 100644
--- a/dev-ruby/rmagick/ChangeLog
+++ b/dev-ruby/rmagick/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/rmagick
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.43 2007/02/22 17:30:05 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.44 2007/03/04 07:59:21 graaff Exp $
+
+*rmagick-1.15.4 (04 Mar 2007)
+
+ 04 Mar 2007; Hans de Graaff <graaff@gentoo.org> +rmagick-1.15.4.ebuild:
+ Version bump:
+
+ * Fixed: RMagick and rbgsl both export the name ID_call
*rmagick-1.15.3 (22 Feb 2007)
diff --git a/dev-ruby/rmagick/files/digest-rmagick-1.15.4 b/dev-ruby/rmagick/files/digest-rmagick-1.15.4
new file mode 100644
index 000000000000..16d00711f876
--- /dev/null
+++ b/dev-ruby/rmagick/files/digest-rmagick-1.15.4
@@ -0,0 +1,3 @@
+MD5 dfdd27cd48a89b8f85425d14fd03126f RMagick-1.15.4.tar.bz2 957803
+RMD160 b5199dce50253dbdcd46d4563b0c372bddd86256 RMagick-1.15.4.tar.bz2 957803
+SHA256 d1e35517557750d0d71ac2045984cb88cee0bea859fcb6c4d192d6384d4f68be RMagick-1.15.4.tar.bz2 957803
diff --git a/dev-ruby/rmagick/rmagick-1.15.4.ebuild b/dev-ruby/rmagick/rmagick-1.15.4.ebuild
new file mode 100644
index 000000000000..9311cea88e6a
--- /dev/null
+++ b/dev-ruby/rmagick/rmagick-1.15.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/rmagick-1.15.4.ebuild,v 1.1 2007/03/04 07:59:21 graaff Exp $
+
+inherit ruby
+
+# The gem for this package doesn't seem to play well with portage. It
+# runs a GNUish configure script, with argument passed directly from
+# the gem install command, but gem install doesn't use the same style
+# of arguments. Thus, unless you're smart enough to come up with a
+# fix, please leave this as a source package install.
+
+DESCRIPTION="An interface between Ruby and the ImageMagick(TM) image processing library"
+HOMEPAGE="http://rmagick.rubyforge.org/"
+SRC_URI="http://rubyforge.org/frs/download.php/18087/RMagick-${PV}.tar.bz2"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="examples doc"
+DEPEND="virtual/ruby
+ >=media-gfx/imagemagick-6.0"
+
+S=${WORKDIR}/RMagick-${PV}
+
+# Using a custom src_compile instead of the ruby one because the ruby
+# one gets confused by an additional setup.rb that should not be used
+# here.
+src_compile() {
+ myconf="${RUBY_ECONF} ${EXTRA_ECONF}"
+
+ # When documentation is built many examples are also run. Not all
+ # of them may work (e.g. due to missing additional dependencies)
+ # so we allow the examples to fail.
+ if ! use doc ; then
+ myconf="${myconf} --disable-htmldoc --enable-allow-example-errors"
+ fi
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --with-ruby=${RUBY} \
+ ${myconf} \
+ "$@" || die "econf failed"
+
+ ruby_emake "$@" || die
+}
+
+# Use a custom src_install instead of the default one in ruby.eclass
+# because the one in ruby.eclass does not include setting the prefix
+# for the installation step.
+src_install() {
+ RUBY_ECONF="${RUBY_ECONF} ${EXTRA_ECONF}"
+
+ ${RUBY} setup.rb config --prefix=${D}/usr "$@" \
+ ${RUBY_ECONF} || die "setup.rb config failed"
+ ${RUBY} setup.rb install --prefix=${D} "$@" \
+ ${RUBY_ECONF} || die "setup.rb install failed"
+
+ cd "${S}"
+ dodoc ChangeLog README.html README-Mac-OSX.txt README.txt
+}