summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-02-15 22:15:53 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-02-15 22:15:53 +0000
commit25e7b251948672541ee8caaf42cbc6148e8dd8fa (patch)
tree5828541170cf75971e7b0d16338d0297460acb60 /dev-ruby
parentold (diff)
downloadgentoo-2-25e7b251948672541ee8caaf42cbc6148e8dd8fa.tar.gz
gentoo-2-25e7b251948672541ee8caaf42cbc6148e8dd8fa.tar.bz2
gentoo-2-25e7b251948672541ee8caaf42cbc6148e8dd8fa.zip
Add patch to work on Ruby 1.9.2 and add ruby19 to the list of compatible implementations.
(Portage version: 2.2.0_alpha23/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/tidy-ext/ChangeLog7
-rw-r--r--dev-ruby/tidy-ext/files/tidy-ext-0.1.10-gentoo.patch88
-rw-r--r--dev-ruby/tidy-ext/tidy-ext-0.1.10.ebuild10
3 files changed, 100 insertions, 5 deletions
diff --git a/dev-ruby/tidy-ext/ChangeLog b/dev-ruby/tidy-ext/ChangeLog
index d42125161dcd..76c6d0a48470 100644
--- a/dev-ruby/tidy-ext/ChangeLog
+++ b/dev-ruby/tidy-ext/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/tidy-ext
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tidy-ext/ChangeLog,v 1.1 2011/01/25 06:50:49 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tidy-ext/ChangeLog,v 1.2 2011/02/15 22:15:53 flameeyes Exp $
+
+ 15 Feb 2011; Diego E. Pettenò <flameeyes@gentoo.org> tidy-ext-0.1.10.ebuild,
+ +files/tidy-ext-0.1.10-gentoo.patch:
+ Add patch to work on Ruby 1.9.2 and add ruby19 to the list of compatible
+ implementations.
*tidy-ext-0.1.10 (25 Jan 2011)
diff --git a/dev-ruby/tidy-ext/files/tidy-ext-0.1.10-gentoo.patch b/dev-ruby/tidy-ext/files/tidy-ext-0.1.10-gentoo.patch
new file mode 100644
index 000000000000..83de729df4cf
--- /dev/null
+++ b/dev-ruby/tidy-ext/files/tidy-ext-0.1.10-gentoo.patch
@@ -0,0 +1,88 @@
+diff --git a/ruby/Rakefile b/ruby/Rakefile
+index 031dfa2..ccd7c91 100644
+--- a/ruby/Rakefile
++++ b/ruby/Rakefile
+@@ -1,6 +1,5 @@
+ require 'rubygems'
+ require 'rake'
+-require 'rake/extensiontask'
+
+ begin
+ require 'jeweler'
+@@ -14,6 +13,8 @@ begin
+ gem.extensions = FileList["ext/**/extconf.rb"]
+ end
+ Jeweler::GemcutterTasks.new
++
++ task :spec => :check_dependencies
+ rescue LoadError
+ puts "Jeweler (or a dependency) not available. Install it with: gem install jeweler"
+ end
+@@ -23,6 +24,7 @@ task :console do
+ exec("irb -I lib -r tidy/alone")
+ end
+
++begin
+ require 'spec/rake/spectask'
+ Spec::Rake::SpecTask.new(:spec) do |spec|
+ spec.libs << 'lib' << 'spec'
+@@ -35,9 +37,10 @@ Spec::Rake::SpecTask.new(:rcov) do |spec|
+ spec.rcov = true
+ end
+
+-task :spec => :check_dependencies
+-
+ task :default => :spec
++rescue LoadError
++ puts "RSpec (or a dependency) not available. Install it with: gem install rspec"
++end
+
+ require 'rake/rdoctask'
+ Rake::RDocTask.new do |rdoc|
+@@ -49,11 +52,16 @@ Rake::RDocTask.new do |rdoc|
+ rdoc.rdoc_files.include('lib/**/*.rb')
+ end
+
++begin
++ require 'rake/extensiontask'
+ Rake::ExtensionTask.new do |ext|
+ ext.name = 'tidy'
+ ext.ext_dir = 'ext/tidy'
+ ext.config_options << '--with-coverage' if ENV['COV']
+ end
++rescue LoadError
++ puts "rake-compiler not available. Install it with: gem install rake-compiler"
++end
+
+ namespace :gcov do
+
+diff --git a/ruby/spec/tidy/compat_spec.rb b/ruby/spec/tidy/compat_spec.rb
+index 0bb1e77..63b285a 100644
+--- a/ruby/spec/tidy/compat_spec.rb
++++ b/ruby/spec/tidy/compat_spec.rb
+@@ -1,4 +1,4 @@
+-require File.join(File.dirname(__FILE__), "..", "spec_helper")
++require "spec_helper"
+
+ describe "tidy compatibility methods" do
+
+diff --git a/ruby/spec/tidy/remote_uri_spec.rb b/ruby/spec/tidy/remote_uri_spec.rb
+index 8426ab7..c3e0ba8 100644
+--- a/ruby/spec/tidy/remote_uri_spec.rb
++++ b/ruby/spec/tidy/remote_uri_spec.rb
+@@ -1,4 +1,4 @@
+-require File.join(File.dirname(__FILE__), "..", "spec_helper")
++require "spec_helper"
+ require 'open-uri'
+
+ describe "tidy class methods" do
+diff --git a/ruby/spec/tidy/tidy_spec.rb b/ruby/spec/tidy/tidy_spec.rb
+index 2ad49e6..bb7ffc7 100644
+--- a/ruby/spec/tidy/tidy_spec.rb
++++ b/ruby/spec/tidy/tidy_spec.rb
+@@ -1,4 +1,4 @@
+-require File.join(File.dirname(__FILE__), "..", "spec_helper")
++require "spec_helper"
+
+ describe "tidy class methods" do
+
diff --git a/dev-ruby/tidy-ext/tidy-ext-0.1.10.ebuild b/dev-ruby/tidy-ext/tidy-ext-0.1.10.ebuild
index 0ed8a025283a..c02dffd87813 100644
--- a/dev-ruby/tidy-ext/tidy-ext-0.1.10.ebuild
+++ b/dev-ruby/tidy-ext/tidy-ext-0.1.10.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tidy-ext/tidy-ext-0.1.10.ebuild,v 1.1 2011/01/25 06:50:49 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tidy-ext/tidy-ext-0.1.10.ebuild,v 1.2 2011/02/15 22:15:53 flameeyes Exp $
EAPI=2
-USE_RUBY="ruby18 ree18"
+USE_RUBY="ruby18 ruby19 ree18"
RUBY_FAKEGEM_DOCDIR="rdoc"
@@ -19,10 +19,12 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE=""
+ruby_add_bdepend "test? ( dev-ruby/rspec:0 )"
+
+RUBY_PATCHES="${FILESDIR}/${P}-gentoo.patch"
+
each_ruby_prepare() {
mkdir lib || die
-
- sed -i -e '/check_dependencies/d' Rakefile || die
}
each_ruby_configure() {