summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-01-15 12:30:59 +0000
committerHans de Graaff <graaff@gentoo.org>2012-01-15 12:30:59 +0000
commit2134b15d9323c2bafd816bd2986f37c0f2cdd10f (patch)
tree9f4d0dff1ee0a3748cc5a1756d9af63cc463424b /dev-ruby
parentbump & remove old (diff)
downloadgentoo-2-2134b15d9323c2bafd816bd2986f37c0f2cdd10f.tar.gz
gentoo-2-2134b15d9323c2bafd816bd2986f37c0f2cdd10f.tar.bz2
gentoo-2-2134b15d9323c2bafd816bd2986f37c0f2cdd10f.zip
Version bump. Add ruby19.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/mini_magick/ChangeLog9
-rw-r--r--dev-ruby/mini_magick/mini_magick-3.4.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/dev-ruby/mini_magick/ChangeLog b/dev-ruby/mini_magick/ChangeLog
index 2e1c44d0b095..23ff47c374f9 100644
--- a/dev-ruby/mini_magick/ChangeLog
+++ b/dev-ruby/mini_magick/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/mini_magick
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mini_magick/ChangeLog,v 1.12 2011/12/21 10:34:01 flameeyes Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mini_magick/ChangeLog,v 1.13 2012/01/15 12:30:59 graaff Exp $
+
+*mini_magick-3.4 (15 Jan 2012)
+
+ 15 Jan 2012; Hans de Graaff <graaff@gentoo.org> +mini_magick-3.4.ebuild:
+ Version bump. Add ruby19.
21 Dec 2011; Diego E. Pettenò <flameeyes@gentoo.org>
mini_magick-1.3.3-r1.ebuild:
diff --git a/dev-ruby/mini_magick/mini_magick-3.4.ebuild b/dev-ruby/mini_magick/mini_magick-3.4.ebuild
new file mode 100644
index 000000000000..d4b28e79a0aa
--- /dev/null
+++ b/dev-ruby/mini_magick/mini_magick-3.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mini_magick/mini_magick-3.4.ebuild,v 1.1 2012/01/15 12:30:59 graaff Exp $
+
+EAPI=2
+
+# jruby → test_tempfile_at_path_after_format fails with jruby 1.3.1,
+# sounds like a bug in JRuby itself, or the code not being compatible.
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Manipulate images with minimal use of memory."
+HOMEPAGE="http://github.com/probablycorey/mini_magick"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# It's only used at runtime in this case because this extension only
+# _calls_ the commands. But when we run tests we're going to need tiff
+# and jpeg support at a minimum.
+RDEPEND="media-gfx/imagemagick"
+DEPEND="test? ( media-gfx/imagemagick[tiff,jpeg] )"
+
+# tests are known to fail under imagemagick 6.5 at least, reported upstream:
+# http://github.com/probablycorey/mini_magick/issues/#issue/2
+# update: still fails with imagemagick 6.6.
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+ruby_add_rdepend ">=dev-ruby/subexec-0.1.0"
+
+all_ruby_prepare() {
+ # remove executable bit from all files
+ find "${S}" -type f -exec chmod -x {} +
+
+ # Remove spec definition part because the gemspec file is not included
+ sed -i -e '/gemspec/,$ d' Rakefile || die
+
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+}