summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-06-06 06:04:27 +0000
committerHans de Graaff <graaff@gentoo.org>2011-06-06 06:04:27 +0000
commit1b25d6d17164c00d69b888e6aade83d0e47cc807 (patch)
tree31ee95b478a255b7c7ef87952576c719b1008042 /dev-ruby
parentLinux-3.0 changes. (diff)
downloadgentoo-2-1b25d6d17164c00d69b888e6aade83d0e47cc807.tar.gz
gentoo-2-1b25d6d17164c00d69b888e6aade83d0e47cc807.tar.bz2
gentoo-2-1b25d6d17164c00d69b888e6aade83d0e47cc807.zip
Remove old versions.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/gherkin/ChangeLog6
-rw-r--r--dev-ruby/gherkin/gherkin-2.3.5.ebuild75
-rw-r--r--dev-ruby/gherkin/gherkin-2.3.6.ebuild72
3 files changed, 5 insertions, 148 deletions
diff --git a/dev-ruby/gherkin/ChangeLog b/dev-ruby/gherkin/ChangeLog
index 224aa6732e83..48b57c795fca 100644
--- a/dev-ruby/gherkin/ChangeLog
+++ b/dev-ruby/gherkin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/gherkin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.22 2011/06/02 09:52:49 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.23 2011/06/06 06:04:27 graaff Exp $
+
+ 06 Jun 2011; Hans de Graaff <graaff@gentoo.org> -gherkin-2.3.5.ebuild,
+ -gherkin-2.3.6.ebuild:
+ Remove old versions.
02 Jun 2011; Hans de Graaff <graaff@gentoo.org> gherkin-2.3.10.ebuild,
+files/gherkin-2.3.10-no-werror.patch:
diff --git a/dev-ruby/gherkin/gherkin-2.3.5.ebuild b/dev-ruby/gherkin/gherkin-2.3.5.ebuild
deleted file mode 100644
index 2b876e982ecc..000000000000
--- a/dev-ruby/gherkin/gherkin-2.3.5.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/gherkin-2.3.5.ebuild,v 1.1 2011/04/12 20:23:45 graaff Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Fast Gherkin lexer and parser based on Ragel."
-HOMEPAGE="http://wiki.github.com/aslakhellesoy/cucumber/gherkin"
-LICENSE="MIT"
-SRC_URI="https://github.com/aslakhellesoy/gherkin/tarball/v${PV} -> ${P}.tgz"
-
-KEYWORDS="~amd64"
-SLOT="0"
-IUSE="doc test"
-
-DEPEND="${DEPEND} dev-util/ragel"
-
-S="${WORKDIR}/aslakhellesoy-gherkin-*"
-
-ruby_add_bdepend "
- dev-ruby/rake-compiler
- test? (
- >=dev-ruby/awesome_print-0.3
- >=dev-ruby/builder-3.0.0
- >=dev-util/cucumber-0.10.0
- >=dev-ruby/rspec-2.5.0
- >=dev-ruby/term-ansicolor-1.0.5
- )"
-
-ruby_add_rdepend ">=dev-ruby/json-1.4.6"
-
-all_ruby_prepare() {
- # Remove Bundler-related things.
- sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb features/support/env.rb || die
- rm Gemfile || die
-
- # Don't use compile dependencies to avoid building again for specs.
- sed -i -e '/:compile/d' Rakefile
-
- # Remove feature that depends on direct access to the cucumber
- # source We could probably set this up by downloading the source
- # and unpacking it, but skipping this now in the interest of time.
- rm features/pretty_formatter.feature || die
-
- # We need to remove this tasks during bootstrapping since it tries
- # to load cucumber already but we can be sure it isn't installed
- # yet.
- if ! use test ; then
- rm tasks/cucumber.rake || die "Unable to remove cucumber tasks."
- fi
-}
-
-all_ruby_compile() {
- if use doc ; then
- rdoc || die "Unable to generate documentation."
- fi
-}
-
-each_ruby_compile() {
- ${RUBY} -I lib -S rake compile || die
-}
-
-each_ruby_test() {
- ${RUBY} -S rake spec || die "Specs failed"
- CUCUMBER_HOME="${HOME}" ${RUBY} -S rake cucumber || die "Cucumber features failed"
-}
diff --git a/dev-ruby/gherkin/gherkin-2.3.6.ebuild b/dev-ruby/gherkin/gherkin-2.3.6.ebuild
deleted file mode 100644
index 96318244323b..000000000000
--- a/dev-ruby/gherkin/gherkin-2.3.6.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/gherkin-2.3.6.ebuild,v 1.1 2011/04/20 05:27:07 graaff Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18"
-
-RUBY_FAKEGEM_TASK_DOC="-Ilib -rgherkin/version -f tasks/rdoc.rake rdoc"
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
-
-RUBY_FAKEGEM_EXTRAINSTALL="VERSION"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Fast Gherkin lexer and parser based on Ragel."
-HOMEPAGE="http://wiki.github.com/aslakhellesoy/cucumber/gherkin"
-LICENSE="MIT"
-SRC_URI="https://github.com/aslakhellesoy/gherkin/tarball/v${PV} -> ${P}.tgz"
-
-KEYWORDS="~amd64"
-SLOT="0"
-IUSE="doc test"
-
-DEPEND="${DEPEND} dev-util/ragel"
-RDEPEND="${RDEPEND}"
-
-S="${WORKDIR}/aslakhellesoy-gherkin-*"
-
-ruby_add_bdepend "
- dev-ruby/rake-compiler
- test? (
- >=dev-ruby/awesome_print-0.3
- >=dev-ruby/builder-3.0.0
- >=dev-util/cucumber-0.10.0
- >=dev-ruby/rspec-2.5.0
- >=dev-ruby/term-ansicolor-1.0.5
- )"
-
-ruby_add_rdepend ">=dev-ruby/json-1.4.6"
-
-all_ruby_prepare() {
- # Remove Bundler-related things.
- sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb features/support/env.rb || die
- rm Gemfile || die
-
- # Don't use compile dependencies to avoid building again for specs.
- sed -i -e '/:compile/d' Rakefile
-
- # Remove feature that depends on direct access to the cucumber
- # source We could probably set this up by downloading the source
- # and unpacking it, but skipping this now in the interest of time.
- rm features/pretty_formatter.feature || die
-
- # We need to remove this tasks during bootstrapping since it tries
- # to load cucumber already but we can be sure it isn't installed
- # yet.
- if ! use test ; then
- rm tasks/cucumber.rake || die "Unable to remove cucumber tasks."
- fi
-}
-
-each_ruby_compile() {
- ${RUBY} -I lib -S rake -rrake/clean -f tasks/compile.rake compile || die
-}
-
-each_ruby_test() {
- ${RUBY} -S rake spec || die "Specs failed"
- CUCUMBER_HOME="${HOME}" ${RUBY} -S rake cucumber || die "Cucumber features failed"
-}