summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-05-23 04:49:53 +0000
committerHans de Graaff <graaff@gentoo.org>2013-05-23 04:49:53 +0000
commit16e57e0420199f9cba1ae8a91b2e7cb196e2fcf0 (patch)
treef9a0dc16a46d04137c387d07160c3255d2ce1481 /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-16e57e0420199f9cba1ae8a91b2e7cb196e2fcf0.tar.gz
gentoo-2-16e57e0420199f9cba1ae8a91b2e7cb196e2fcf0.tar.bz2
gentoo-2-16e57e0420199f9cba1ae8a91b2e7cb196e2fcf0.zip
Version bump.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/amq-client/ChangeLog7
-rw-r--r--dev-ruby/amq-client/amq-client-1.0.2.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-ruby/amq-client/ChangeLog b/dev-ruby/amq-client/ChangeLog
index cb207265e8b8..ecd803329dda 100644
--- a/dev-ruby/amq-client/ChangeLog
+++ b/dev-ruby/amq-client/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/amq-client
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amq-client/ChangeLog,v 1.7 2013/04/27 07:06:35 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amq-client/ChangeLog,v 1.8 2013/05/23 04:49:53 graaff Exp $
+
+*amq-client-1.0.2 (23 May 2013)
+
+ 23 May 2013; Hans de Graaff <graaff@gentoo.org> +amq-client-1.0.2.ebuild:
+ Version bump.
*amq-client-0.9.12 (27 Apr 2013)
diff --git a/dev-ruby/amq-client/amq-client-1.0.2.ebuild b/dev-ruby/amq-client/amq-client-1.0.2.ebuild
new file mode 100644
index 000000000000..ae5c2f7bf73c
--- /dev/null
+++ b/dev-ruby/amq-client/amq-client-1.0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amq-client/amq-client-1.0.2.ebuild,v 1.1 2013/05/23 04:49:53 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.textile"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit versionator ruby-fakegem
+
+DESCRIPTION="A fully-featured, low-level AMQP 0.9.1 client."
+HOMEPAGE="http://github.com/ruby-amqp/amq-client"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/amq-protocol-1.2.0 dev-ruby/eventmachine"
+
+ruby_add_bdepend "test? ( dev-ruby/evented-spec )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/ s:^:#:' -e '/effin_utf8/ s:^:#:' spec/spec_helper.rb || die
+ sed -i -e '7i require "evented-spec"' spec/spec_helper.rb || die
+
+ # Drop integration tests since these require a running AMQP server.
+ rm -rf spec/integration spec/regression/bad_frame_slicing_in_adapters_spec.rb spec/unit/client_spec.rb || die
+}