summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2006-06-13 12:46:11 +0000
committerCaleb Tennis <caleb@gentoo.org>2006-06-13 12:46:11 +0000
commit105b3313938555923f37f525652e79e404342835 (patch)
treea844e8e15cde971d1a76fdd72e66c87c2a1bcb64 /dev-ruby
parentRepoman really should have detected this major tree breakage. ALWAYS quote yo... (diff)
downloadgentoo-2-105b3313938555923f37f525652e79e404342835.tar.gz
gentoo-2-105b3313938555923f37f525652e79e404342835.tar.bz2
gentoo-2-105b3313938555923f37f525652e79e404342835.zip
remove a couple of headers that weren't allowing it to build against qt 4.1.3
(Portage version: 2.1)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/qt4-qtruby/ChangeLog6
-rw-r--r--dev-ruby/qt4-qtruby/files/style-fix.diff18
-rw-r--r--dev-ruby/qt4-qtruby/qt4-qtruby-1.4.5.ebuild11
3 files changed, 32 insertions, 3 deletions
diff --git a/dev-ruby/qt4-qtruby/ChangeLog b/dev-ruby/qt4-qtruby/ChangeLog
index b347a30d8db0..072d1c5345ab 100644
--- a/dev-ruby/qt4-qtruby/ChangeLog
+++ b/dev-ruby/qt4-qtruby/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/qt4-qtruby
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/qt4-qtruby/ChangeLog,v 1.2 2006/05/17 14:26:19 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/qt4-qtruby/ChangeLog,v 1.3 2006/06/13 12:46:11 caleb Exp $
+
+ 13 Jun 2006; Caleb Tennis <caleb@gentoo.org> +files/style-fix.diff,
+ qt4-qtruby-1.4.5.ebuild:
+ Remove a couple of headers that weren't allowing it to build against Qt 4.1.3
17 May 2006; Ferris McCormick <fmccor@gentoo.org> qt4-qtruby-1.4.5.ebuild:
Add ~sparc keyword. Can be built and runs examples. NOTE: On SMP systems,
diff --git a/dev-ruby/qt4-qtruby/files/style-fix.diff b/dev-ruby/qt4-qtruby/files/style-fix.diff
new file mode 100644
index 000000000000..fadf2741c27e
--- /dev/null
+++ b/dev-ruby/qt4-qtruby/files/style-fix.diff
@@ -0,0 +1,18 @@
+--- smoke/qt/header_list 2006/06/02 19:11:49 547618
++++ smoke/qt/header_list 2006/06/06 16:08:19 548844
+@@ -92,7 +92,6 @@
+ QtGui/qboxlayout.h
+ QtGui/qbrush.h
+ QtGui/qbuttongroup.h
+-QtGui/qcdestyle.h
+ QtGui/qcheckbox.h
+ QtGui/qclipboard.h
+ QtGui/qcolordialog.h
+@@ -152,7 +151,6 @@
+ QtGui/qmenu.h
+ QtGui/qmessagebox.h
+ QtGui/qmime.h
+-QtGui/qmotifstyle.h
+ QtGui/qmovie.h
+ QtGui/qpagesetupdialog.h
+ QtGui/qpaintdevice.h
diff --git a/dev-ruby/qt4-qtruby/qt4-qtruby-1.4.5.ebuild b/dev-ruby/qt4-qtruby/qt4-qtruby-1.4.5.ebuild
index 14f3b99ee909..9faf2fb6ef0d 100644
--- a/dev-ruby/qt4-qtruby/qt4-qtruby-1.4.5.ebuild
+++ b/dev-ruby/qt4-qtruby/qt4-qtruby-1.4.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/qt4-qtruby/qt4-qtruby-1.4.5.ebuild,v 1.5 2006/06/06 11:55:10 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/qt4-qtruby/qt4-qtruby-1.4.5.ebuild,v 1.6 2006/06/13 12:46:11 caleb Exp $
-inherit toolchain-funcs
+inherit toolchain-funcs eutils
DESCRIPTION="Ruby bindings for QT4"
HOMEPAGE="http://rubyforge.org/projects/korundum"
@@ -19,6 +19,13 @@ DEPEND=">=virtual/ruby-1.8
SLOT="0"
+src_unpack() {
+ unpack $A
+ cd ${S}
+ epatch ${FILESDIR}/style-fix.diff
+}
+
+
src_compile() {
myconf="--with-qt-dir=/usr --with-qt-libraries=/usr/$(get_libdir)/qt4 --with-qt-includes=/usr/include/qt4"
myconf="${myconf} --with-threshold=5"